PlatformIO Community

Examples not recognized

Hi everyone.

At first I thought that I was missing something, but after a lot of investigations, I can’t find anything wrong. My latest library, BootInfo, has an example that’s not showing, see here.

Can someone point out what’s wrong?

Thanks a lot.

The manifest isn’t showing either, but confusingly the PIO Registry knows where it lives, since when I hit the ‘edit’ button it opens up on GitLab. I noticed your NMEAParser library is in the same state. Nothing jumps out as being wrong though.

btw, Any chance you can add a screenshot of what something like SimpleTest looks like to the readme for that library? I was just looking at it, and it would be nice to get and idea of what the fuss is all about. i.e. Why would I want to use it? :stuck_out_tongue_winking_eye:

@ivankravets Does the crawler need another prod? :wink:

1 Like

You nailed it, my other lib is in the very same situation. Through a few tests I tried to sold the issue, but nothing worked. I’m starting to wonder if the issue is not related to Gitlab…

And yes, I will definitely put more into into the README. Meanwhile you can check the release page if you’re curious :wink:

1 Like

Oh, very nice! I might borrow some of that for use with the ESP8266 :wink:

1 Like

I’m planning to port it to the ESP8266/12E very soon, and also to reduce the bond to the Arduino framework :wink:

1 Like

The result is OK. You pointed library.json to downloadUrl that does not have examples in the root unpacked archive. The short answer:

  1. Remove downloadUrl
  2. Set repository.url to https://gitlab.com/X99/bootinfo.git

PlatformIO will automatically d t he rest work for you.

2 Likes

Thank you @ivankravets