Esp8266 SmartConfig doesn't connect to WIFI

Hey all!

I’m trying to use esp8266 smart config but it fails to connect. There’s no error message show and after inspecting the smart config app udp message using WireShark, I see that the udp messages are sent correctly.

These are the esp logs:
Screen Shot 2022-10-14 at 18.44.27

Wireshark logs will be attached in the next comment*

My esp code:

#include <Arduino.h>
#include <ESP8266WiFi.h>
#include <WiFiUdp.h>
#include "smartconfig.h"

void setup() {
  // put your setup code here, to run once:
  // timeout
  while (WiFi.status() != WL_CONNECTED) {
  Serial.println("WiFi connected");  


void loop() {
  // put your main code here, to run repeatedly:


I’ve tried adding some more logs in _smartConfigCallback to find out what actually happens and it looks like it’s trying to find a channel.

Also, I saw that my smartconfig version is v2.5.4 and in other posts, I see that people are using version 2.9.0. Tried looking for a way to upgrade the version but found no resources on that as well.

Is it an issue with the version of smartconfig that I’m using? Is there a way to view more debugging logs so I could figure out what the exact issue is?

Thanks a lot!

WireShark captured UDP packets:
Screen Shot 2022-10-14 at 18.45.14

Is this issue reproducible in the Arduino IDE with the latest Arduino-ESP32 2.0.5 core?

Well, I’m using this as my board:

It looks like 3.0.2 is the latest stable version: GitHub - esp8266/Arduino: ESP8266 core for Arduino

My bad, I thought of ESP32.

So it works in the Arduino IDE + latest esp8266 core version?

No, it doesn’t.

Okay, then it’s not a directly PlatformIO related problem. Can you open an issue at Issues · esp8266/Arduino · GitHub to get help from the developers?

Sure, I’ll open an issue. Although my guess is that my smartconfig version is out of date and I would like to update it in PlatformIO.

Opened an issue here: Smartconfig fails to retrieve WiFi credentials · Issue #8691 · esp8266/Arduino · GitHub

We supply what Arduino-ESP8266 releases as stable.

matches the latest stable 3.0.2 release.

Of course, if you suspect it is already fixed in the git mainline version, then as documented, tell PlatformIO to pull that bleeding edge version.

platform_packages =
  framework-arduinoespressif8266 @