ESP8266 not found using Atom


#1

Hi,
I am trying to use PlatformIO via Atom, to build and upload to an ESP8266 (Node MCU, ESP-12E). I’ve installed the CP210X Drivers, as noted on the board itself, but I only get:

MacBook-Pro-3:smart-bed-sensor-master mfd356$ pio device list
/dev/cu.Bluetooth-Incoming-Port
-------------------------------
Hardware ID: n/a
Description: n/a

/dev/cu.iPhone-WirelessiAPv2
----------------------------
Hardware ID: n/a
Description: n/a

I’m using Atom v. 1.32.2 64x and PlatformIO (home: 1.0.6), (core: 3.6.2b5) on OSX High Sierra (XCode v 10.1).

This is my first attempt with both PlatformIO and an ESP8266 board, so it’s very likely that it’s something stupid that I just haven’t figured out, or been able to google.


#2

Are you able to see the the serial port / board under the USB settings? Can you upload via Arduino IDE? If not, your problem is that you didn’t install the drivers correctly, didn’t reboot or installed the wrong drivers.


#3

I suspect you’re right about the drivers.

After installing the ones that were described on the board, I see something under the OS device manager (or whatever they call it on OSX) when connecting the board.

But nothing showed up in the Arduino IDE ports, just the two I initially found via PlatformIO.

I’ve subsequently installed other drivers; I tried this guide, that links to drivers published by codebender, as we as these drivers but same story.

I have rebooted each time after installing drivers. I’m not sure if there is a wrong way to install the drivers; they come as either .pkg or .dmg, so it’s just running it.

Any idea about which drivers would actually work? None of the ones I have found seem to do the job.


#4

I never got this to work on OSX.

However, I dusted off my old Windows Desktop, installed drivers (found on the same website as the initial ones I tried on the Mac), and this worked with no issues.