ESP8266 error on remote uploading

I installed core on my remote linux machine and it runs fine but when I execute and upload from another location I get this error.
I’ve tried to remove .platformio directory and reinitialize but no luck.
When I run “platformio update” it shows esp8266 installed

Error: Could not find ‘eagle.flash.4m1m.ld’ LD script in LDPATH ‘/home/pi/.platformio/remote/projects/Freezer Alarm-d4a3c214ac103c256adf417b8baf78f22b419df2/.pioenvs/huzzah’

full debug log here

This is a bug. Please file an issue here Issues · platformio/platform-espressif8266 · GitHub

Temporary solution

Please run 1 time with pio remote run --force-remote command

Does it work now?

opened issue

Your command says successful.

PIO Plus () v1.4.2
Processing huzzah (platform: espressif8266; board: nodemcuv2; framework: arduino)

Verbose mode can be enabled via -v, --verbose option
PLATFORM: Espressif 8266 > NodeMCU 1.0 (ESP-12E Module)
SYSTEM: ESP8266 80MHz 80KB RAM (4MB Flash)
Library Dependency Finder → Library Dependency Finder (LDF) — PlatformIO latest documentation
Collected 26 compatible libraries
Scanning dependencies…
No dependencies
Compiling .pioenvs/huzzah/src/main.cpp.o
Linking .pioenvs/huzzah/firmware.elf
Calculating size .pioenvs/huzzah/firmware.elf
text data bss dec hex filename
254455 1280 29944 285679 45bef .pioenvs/huzzah/firmware.elf
Building .pioenvs/huzzah/firmware.bin
======================== [SUCCESS] Took 8.22 seconds ========================

It does not flash the device.