Esp32 Wrover-Kit,Error: JTAG scan chain interrogation failed


#1

Hello,
I am using VSC + Platformio, connected to a ESP-Wrover-kit board… I setup the Hello_World project, and everything as per manuals/documentations…
I am on a Win10 platform using Visual Studio Code and already updated FT drivers with Zadig…

My platformio.ini :

[env:esp-wrover-kit]
platform = espressif32
board = esp-wrover-kit
framework = espidf
monitor_port = COM16
monitor_speed = 115200
debug_tool = ft2232h

On the board I can compile, upload, run the code, look at serial monitor output, everything seems to work fine, but I can not debug it… As I start a debugging session, it appears like the CPU’s chain interrogation fails, and get a list of errors from then on… I have read a lot of stuff about this problems, and tested many solutions, but no way out… Could any1 give me a suggestion…?

Here the Debugger Log:

Licensed under GNU GPL v2
For bug reports, read
http://openocd.org/doc/doxygen/bugs.html
none separate
adapter speed: 20000 kHz
esp32 interrupt mask on
force hard breakpoints
Info : tcl server disabled
Info : telnet server disabled
Error: libusb_open() failed with LIBUSB_ERROR_NOT_SUPPORTED
Info : ftdi: if you experience problems at higher adapter clocks, try the command “ftdi_tdo_sample_edge falling”
Info : clock speed 20000 kHz
Error: JTAG scan chain interrogation failed: all ones
Error: Check JTAG interface, timings, target power, etc.
Error: Trying to use configured scan chain anyway…
Error: esp32.cpu0: IR capture error; saw 0x1f not 0x01
Warn : Bypassing JTAG setup events due to errors
Info : esp32: Debug controller was reset (pwrstat=0xFF, after clear 0xFF).
Info : esp32: Core was reset (pwrstat=0xFF, after clear 0xFF).
Error: cpu0: esp32_fetch_all_regs (line 171): DSR (FFFFFFFF) indicates target still busy!
Error: cpu0: esp32_fetch_all_regs (line 171): DSR (FFFFFFFF) indicates DIR instruction generated an exception!
Error: cpu0: esp32_fetch_all_regs (line 171): DSR (FFFFFFFF) indicates DIR instruction generated an overrun!

and goes on…

Thanks

Kind Regards

Alex


#2

Solved…!!! It was a bad contact on JP8…


#3

We did important updates for PIO IDE for VSCode and PIO Plus.

  1. Please update PIO IDE for VSCode to 0.17.1, we fixed different issues with debugger
  2. Open PIO IDE Terminal and type pio update.

Now, debugging for ESP32 should work without any issues. Please confirm.


#4

Hello,

I configm now the Debug on ESP32 is improved, still not gone deeply into it, but it appears faster and ‘watches’ now appear to work correctly…

Thanks

Alex