ESP32 S3 16MB SPI Flash no spram can't get it to work

Hello everyone
i am trying to make my esp32 s3 work but impossible i am desperately looking for where the problem can come from i have searched all the internet and i have not found anything
I get reboot about every 10 seconds with this message that I attached as an image
Thank you in advance for your assistance :slight_smile:

Use this chip there S3-WROOM-1-N16:

and I use this support to program and test it:

And those reboots happen even with an empty sketch?

yes even empty it reboots about every 10 to 20 seconds with this same message

Does it work in the Arduino IDE? If yes with what settings?

Have you tried the regular espressif32 platform, not Jason2866’s?

I don’t use Arduino at all I don’t like at all I only use platformio and Visual Studio

Try to add these sentences in yout file:

build_flags = 
board_build.arduino.memory_type = qio_opi

The second one not sure now if it’s necessary, but you can try.

This worked to me with my ESP32-S3 with PSRAM memory.

I therefore tested on Arduino we can send code it runs but ends up crashing quickly on platformio the code does not run at all and crashes every 10 seconds

I had the same issue. The only fix I found was to make sure you dont have VScode open and then delete the .platformio folder. Then open VScode and let it install everything again.

Found restart issue behavior on similar n16r8 module. Resolved by closed io0 to gnd. Also used board json from