ESP32-S2 ESP32S2 Saola Support

Just wondering if anyone knows of a hopeful timeline for inclusion to support the new ESP32-S2?

Referencing, board_build.mcu = esp32s2, seems to compile but bin is not right and will not correctly flash as obviously not currently supported.

Chip is unknown ESP32 (revision 1)
Features: WiFi, Single Core, Embedded Flash, VRef calibration in efuse, Coding Scheme Repeat (UNSUPPORTED)

Many thanks


Any news on this? Is the support available now?

The ESP32-S2 is not supported by the espressif ESP32 Arduino core main branch yet, and is only via a specific esp32s2 branch if I understand the situation correctly. This seems to be the current state of affairs still: When will ESP32-S2 add to Arduino? - ESP32 Forum

PS: I would think (I’ve not tried this) that it would be possible to use that branch with PlatformIO by following the documentation here, and pointing it to that branch, not just the repo generally. Espressif 32 — PlatformIO latest documentation

1 Like

I’m currently trying to get this to work, my platformio.ini now has this line:

platform_packages =
    platformio/framework-arduinoespressif32 @

but it does not seem to make a difference:

rocessing esp32dev (platform: espressif32; board: esp32-s2-kaluga-1; framework: arduino)
Verbose mode can be enabled via `-v, --verbose` option
PLATFORM: Espressif 32 (3.1.0) > Espressif ESP32-S2-Kaluga-1 Kit
HARDWARE: ESP32S2 240MHz, 320KB RAM, 4MB Flash
DEBUG: Current (esp-prog) External (esp-prog, iot-bus-jtag, jlink, minimodule, olimex-arm-usb-ocd, olimex-arm-usb-ocd-h, olimex-arm-usb-tiny-h, olimex-jtag-tiny, tumpa)
 - framework-arduinoespressif32 0.0.0+sha.cf60cf4  
 - tool-esptoolpy 1.30000.201119 (3.0.0) 
 - tool-openocd-esp32 2.1000.20201202 (10.0) 
 - toolchain-esp32s2ulp 1.22851.191205 (2.28.51) 
 - toolchain-xtensa32s2 1.80400.210211 (8.4.0)
Error: This board doesn't support arduino framework!

apparently i’m doing it wrong, it does not even seem to try to install the esp32-s2 branch :thinking:

edit: actually looking at it it seems to fail to install the branch since its version 0.0.0 …

Per Add support for ESP32-S2 Dev Boards · Issue #349 · platformio/platform-espressif32 · GitHub the board isn’t supported with the Arduino framework on the PlatformIO side currently, but ESP-IDF. I’m not sure if it’s usable in the Arduino-IDE / Arduino-ESP32 at this point though.

CC @valeros maybe you know more?

1 Like

you guys are so amazingly fast with replies it keeps baffling me :scream: much appreciated!

I do not specifically use that board but a custom board with debug pins connected to an esp-prog. as far as I have gathered it is all about espressivs arduino-esp32 implementation, or did I misunderstand this?
I found a bunch of guides for arduino ide which apparently i do not use, so that’s where my assumption comes from.

ESP32-S2 support in the Arduino framework is still not stable, although there is a special branch of the espressif32 platform that pulls the latest Arduino package with initial changes for ESP32-S2. You can use it in your configuration:

platform =
framework = arduino
board = metroesp32-s2

this worked great, thank you!

Unfortunately the idf-v.4.2 has a defect regarding the USB-Serial.
It appears to be fixed idf-v.4.3
Is it possible to update the branch to use 4.3 or are the changes to be made for that to extensive?

Thanks Ralf