ESP32-PROG Serial ports

I have a ESP32-PROG for JTAG debugging. Following this instruction ( ESP-Prog — PlatformIO latest documentation ) it worked pretty well , despite one problem.

With regular intervals PlatformIO lost connection with the ESP32-PROG. Checking the device list ( PlatformIo command) I notice that the serial channels are gone. Normally I performed a new install followed by the instructions above to get it work again, normally…

At the moment, despite all my efforts, I cant get JTAG debugging again. I’ve removed, reinstalled etc, no luck.

Anyone who can advice???

What operating system?

Have you been able to determine whether it is PlatformIO that is losing the connection, or is your operating system itself reporting it no longer connected? Perhaps the device, cable or USB connection is faulty?

It sounds like a hardware problem, either the USB cable/port to the ESP32-Prog or a hardware misconfiguration of the ESP32-Prog.

I’ve had a smiliar effect with a USB-to-Serial converter that I had incorrectly connected to a MCU board. The USB-to-Serial converted uses an FTDI chip similar to the one on ESP32-Prog.

1 Like

I am running windows 10.

Doupt it is a hardware problem. Everything works nicely a couple of days, suddenly it stops.

My feeling is that my problems have to do with windows plug and play and platformio auto detect.

I noticed that platformio tried to use a usb/Com port connected to my 3D printer. Removing the printer removed all problems.

Since you’re on windows, if you randomly hear it chip to say USB device disconnected, it’s not PlatformIO’s fault… it’s something in the OS or more likely some hardware glitch (USB port/cable/ESP32-PROG usb connector).

The other issue can be, as Manuel suggested, that your printer has a similar USB UART chip chip to the ESP32-PROGs, and PlatformIO doesn’t know which one to use. Although that wouldn’t explain why it wouldn’t show up in the device list.

Other possibility that might be worth pursuing is checking if your 3D printer overloading your USB ports. I had the misfortune of having one that in their infinite wisdom the manufacturer didn’t isolate the 5V supply on the printer from the USB 5V (it would only have taken a single diode!!!) so it could back-feed in to the USB ports on the computer… and bad things happened to some computers and the protection circuitry in others got a good workout! :-/