Esp32 platformio littlefs never, spiffs.bin always

I’ve followed several discussions on how to get littleFS to work, as it is the apparent successor to spiffs. But it always seems to go to spiffs.
Things I’ve tried.

  1. Added board_build.filesystem = littlefs to platformio.ini (which seems wrong since I want to use this in all projects not just the current one).
  2. I’ve tried to follow arduino-esp32/libraries/LittleFS/examples/LITTLEFS_PlatformIO at master · espressif/arduino-esp32 · GitHub which seemed like the end result of the discussions. Many problems, I’m not sure if he’s using some shorthand lingo, or just expects me to know what he’s talking about.
  • Download and extract to this project root a mklittlefs executable for your OS from a zipped binary here
  • Open LITTLEFS_PlatformIO folder
  • Run PlatformIO project task: Upload Filesystem Image
  • Run PlatformIO project task: Upload and Monitor
  • You will see a Serial output like:

I don’t know if project root is my project root or this project root I’m downloading.
I don’t have a LITTLFS_PlatofromIO folder, so I assume I’m supposed to create it? Where?
The rest makes sense to me, but without installing correctly (I tried putting it in several places, no idea where it’s supposed to go).

I’ve gotten it to work with the “clunky old Arduino” software, so I’ve got the idea of what’s supposed to happen, but I’ve been all day trying to get platformIO to work and it’s not happening.

Are there actually clear instructions on installing this?

I’m running on Linux, using esp32dev board.

The name of the project is LITTLEFS_PlatformIO. They just mean to open this example that that they’ve prepared.