Esp32 not detected as device in upload port

I have the problem that my esp32 boards are not detected in the device manager or the upload port (configuration of a project). The Arduino is however detected and I can upload data to it. I am using windows. In the screenshot below you can see what happens when I plug in both an Arduino Uno and an Esp32, only the former is shown as COM3. Do you have a solution?

Greetings, Philipp

P.S: The Esp32s and the USB cable work correctly with the Arduino IDE. I don’t think they cause the issue.

1 Like

What kind of ESP32 device do you have? Other than the Arduino, it might require the installation of an appropriate driver.

For understanding your problem, it might be helpful if you could provide a screen of the device manager with all USB sections expanded.

1 Like

Thank you for the reply! I am using an Esp-Wroom-32. Here is my device manager with the board connected, it is shown as CP2102… in the second row. I tried installing a driver, but there is nothing alike on my computer.

1 Like

The warning in the device icon clear indicates that the device is not fully working.

What kind of drivers have you installed? And what was the result?

The official drivers from the manufacturer (Silicon Labs) are at

Once the drivers are correct installed, the device will no longer appear under Other devices / Andere Geräte but under Ports (COM & LPT) / Anschlüsse (COM & LPT).

1 Like

Hi Manuelbl, after installing the drivers, the Esp-WROOM-32 is shown as a COM port. I can also see it in the device manager of platformio - Problem solved!
To everyone who has the same problem: Check if the driver is installed (Is the Board shown under “other device”? If yes, try installing the driver). You can download it from: Extract everything and open the installer program (64bits). Follow the instructions. Afterwards, your problem is most likely solved.

Thanks again to @manuelbl!

1 Like

I found the reason why my computer does not recognize the ESP module. The device ID on any computer is unknown, and the cause is hidden in a poorly placed USB micro connector.