Esp32_i2s import includepath

I’m trying to import the built-in esp32 i2s header with:

#include <ESP_I2S.h>

but it’s throwing:

#include errors detected. Please update your includePath. Squiggles are disabled for this translation unit.

I have tried to rebuild the intellisense index but it’s still not finding it; am I supposed to separately download esp32-arduino to get these?


There is no builtin “ESP_I2S.h” but I2S.h

thanks, but that’s v2, v3 onwards uses ESP_I2S now

But Arduino 3.x ist not yet available to PlatformIO!

is there a beta branch or a way to make use of this? in arduino IDE I can pull v3

PlatformIO != ArduinoIDE

Espressif32 Arduino 3.x has not (yet) been released by PlatformIO

But you can try

  framework-arduinoespressif32 @
  framework-arduinoespressif32-libs @
1 Like

yeah sorry I know they are two separate projects, just was saying that’s where it worked for me before migrating to PIO, trying out your snippet right now and will report back after “configuring toolchain packages from a remote source” runs through :slight_smile: appreciate it

that seems to have fixed it, thanks for you incredibly fast response! appreciate it

1 Like