ESP32 I2C takes wrong pins

So i want to use I2C with my WT32-SC01 Plus. When i use the Wire.begin(SDA_PIN,SCL_PIN, freq); it just always uses IO10 as SCL and any other as SDA, didn’t figure out which one yet. Since i need it on IO10 for SCL and IO11 for SDA i need to be able to adjust the pins.
My platformio.ini looks like this:

platform = espressif32
board = um_tinys3
framework = arduino
upload_speed = 921600
monitor_speed = 115200
; upload_port = COM7
board_build.partitions = max_app_8MB.csv
;board_build.partitions = no_ota.csv
build_flags = 
	-I src/ui/
	-I src/
lib_deps = 

Has anyone experienced such a problem before/can anyone help?

Have you tried an absolute minimal project and code like the I2C Scanner with only the Wire.begin() call adapted to your Wire.begin(SDA_PIN,SCL_PIN, freq); and see if it can find any devices? The needed platformio.ini should just be

platform = espressif32
board = um_tinys3
framework = arduino

Yes i tried it once, it worked fine and did again just now.

Then the conclusion is that the base code works just fine but something messes it up in your more complex project. Maybe another Wire.begin() with different arguments. Without seeing the code, or using a debug probe, that’s impossible to say.

Ohh that brings me to the idea that my lvgl part with the touchscreen library could use I2C too… Thanks!