ESP32 E (27): nothing to load

Hi PlatformIO Community,

Got a question regarding the ESP32 microcontroller and PIO,
If I execute the command pio run --target upload the platform correctly installs the toolchain, loads the program but program is not being executed - same issue for ESP-IDF and ESP-Arduino examples.
Looking at the serial monitor I see the following message: E (27) boot: nothing to load. Does this imply that the firmware was loaded into the wrong memory area?
I found a similar issue on PlatformIO github page as it relates to the board DOIT ESP32. I am using an ESP32DEV board.

Has this issue being resolved by PlatformIO?

My current course of action is to manually install the ESP-IDF toolchain /w Arduino as a component and flash using ESPTool.
I don’t want to use Arduino IDE hence this direction. Any suggestions are as always appreciated.


Could you try this solution?

advice holding the boot button for first flash

@ivankravets as always, thanks for your response!
I tried the suggested approach but unfortunately that results in the same error.