ESP32 Dev Module project creation error

PIO Core Call Error: “The current working directory A:\Embedded\Projects\ESP32_test\esp32_test_v0.1 will be used for the project.\r\n\r\nThe next files/directories have been created in A:\Embedded\Projects\ESP32_test\esp32_test_v0.1\r\ninclude - Put project header files here\r\nlib - Put here project specific (private) libraries\r\nsrc - Put project source files here\r\nplatformio.ini - Project Configuration File\r\n\n\nError: Processing esp32dev (platform: espressif32; board: esp32dev; framework: espidf)\r\n--------------------------------------------------------------------------------\r\nPackageManager: Installing toolchain-xtensa32 @ ~2.80200.0\r\ntoolchain-xtensa32 @ 2.80200.200226 has been successfully installed!\r\nPackageManager: Installing toolchain-esp32ulp @ ~1.22851.190618\r\ntoolchain-esp32ulp @ 1.22851.190618 has been successfully installed!\r\nPackageManager: Installing framework-espidf @ ~3.40001.0\r\nframework-espidf @ 3.40001.200521 has been successfully installed!\r\nPackageManager: Installing tool-mconf @ ~1.4060000.0\r\ntool-mconf @ 1.4060000.20190628 has been successfully installed!\r\nPackageManager: Installing tool-idf @ ~1.0.1\r\ntool-idf @ 1.0.1 has been successfully installed!\r\nVerbose mode can be enabled via -v, --verbose option\r\nCONFIGURATION:\r\nPLATFORM: Espressif 32 1.12.4 > Espressif ESP32 Dev Module\r\nHARDWARE: ESP32 240MHz, 320KB RAM, 4MB Flash\r\nDEBUG: Current (esp-prog) External (esp-prog, iot-bus-jtag, jlink, minimodule, olimex-arm-usb-ocd, olimex-arm-usb-ocd-h, olimex-arm-usb-tiny-h, olimex-jtag-tiny, tumpa)\r\nPACKAGES: \r\n - framework-espidf 3.40001.200521 (4.0.1) \r\n - tool-cmake 3.16.4 \r\n - tool-esptoolpy 1.20600.0 (2.6.0) \r\n - tool-idf 1.0.1 \r\n - tool-mconf 1.4060000.20190628 (406.0.0) \r\n - tool-ninja 1.9.0 \r\n - toolchain-esp32ulp 1.22851.190618 (2.28.51) \r\n - toolchain-xtensa32 2.80200.200226 (8.2.0)\r\nInstalling ESP-IDF’s Python dependencies\r\n’c:\users\abhinav’ is not recognized as an internal or external command,\r\noperable program or batch file.\r\n*** Error 1\r\nError: Detected a whitespace character in project paths.\r\n========================= [FAILED] Took 109.28 seconds =========================”

This is the error message I get when trying to create a new project for espressif ESP32 Dev Module using Espressif IoT development Framework. Tyhe project is created but the entire .vscode folder is missing. I am thus not able to include any header files also.
I have tried changing the location of project creation to no avail. I have also tried reinstalling the Espressif 32 platform.
This error is NOT generated when I try to create a project for my F429 discovery board in the same location.

Please have a look at

Sounds a little bit like this problem to me.