ESP32 Cannot configure port

Hi everybody,

I’m facing a curious problem with two Lenovo laptops (one ThinkPad, one Legion), the same ESP32 (SC01 Plus) card, and two fresh installations of VSCode and PlatformIO. I’m trying to upload the exact same program on both computers.

On the first computer (ThinkPad), it compiles and uploads without any problems. However, on the second computer (Legion), the COM port can’t be opened. Nothing else is using the COM port on the Legion (I’ve tried rebooting and starting VSCode again) and the terminal is not open.

This is what I get on the Legion when it’s not working:

And this is what I get on the ThinkPad when it’s working:

RAM: [=== ] 28.4% (used 92956 bytes from 327680 bytes)
Flash: [== ] 16.9% (used 564837 bytes from 3342336 bytes)
Building .pio\build\esp32s3\firmware.bin v4.5.1
Creating esp32s3 image…
Merged 2 ELF sections
Successfully created esp32s3 image.
Configuring upload protocol…
AVAILABLE: cmsis-dap, esp-bridge, esp-builtin, esp-prog, espota, esptool, iot-bus-jtag, jlink, minimodule, olimex-arm-usb-ocd, olimex-arm-usb-ocd-h, olimex-arm-usb-tiny-h, olimex-jtag-tiny, tumpa
CURRENT: upload_protocol = esptool
Looking for upload port…
Auto-detected: COM4
Forcing reset using 1200bps open/close on port COM4
Waiting for the new upload port…
Uploading .pio\build\esp32s3\firmware.bin v4.5.1
Serial port COM5
Chip is ESP32-S3 (revision v0.2)

The Windows drivers are identical on both machines.

I tried deleting the User/Owner/.platformio/package directory to reload all the packages, but I got the same result. I also tried uninstalling and reinstalling VSCode and PlatformIO, but the problem persists.

If anyone has any ideas, I would really appreciate it. I’ve been struggling with this issue for a week now.

Thank you very much for your help.

Just forgot to specify, the ESP32-S3 stop (from the both computers) after trying to upload the program, in one case it upload, in the other case we have an error, in both case the ESP32-S3 stop working. they can start again after pressing on Reset button.
I still stuck on this problem for 2 weeks now and still can’t understand what’s going on…

Thank you if you have any idea, please let me know.