Errors when trying to load old design after long absence

After long time I needed to re-program ESP32 device. After loading the VScode and doing all the upadetes, something is not working well. The design was working in the past (more than a year ago), yet now I can’t even get to compile it. When looking at the sopurce code, all the includes are not valid, even simple ones like Arduino.h. The error reported is:

#include errors detected. Please update your includePath. Squiggles are disabled for this translation unit cannot open source file "Arduino.h"C/C++(1696)

Looking at the terminal, this message appears:

Processing esp32dev (platform: espressif32; board: esp32dev; framework: arduino)
------------------------------------------------------------------------------------------------------------------Tool Manager: Installing platformio/tool-esptoolpy @ ~1.40501.0
Tool Manager: Error: Please read Redirecting...
Tool Manager: Warning! Package Mirror: HTTPSConnectionPool(host=‘’, port=443): Max retries
exceeded with url: /fd833e6c4db04192b0ad7e561907b935:pioregmirrorsg/tools/7a/e7/0cf60b9c681713575c6761bebe3c7b5387dfa80bbaa1aa78eac41efa50ab/tool-esptoolpy-1.40501.0.tar.gz (Caused by ConnectTimeoutError(<urllib3.connection.HTTPSConnection object at 0x000001F82501D010>,SConnection object at 0x000001F82501D010>, ‘Connection to timed out. (connect timeout=10)’))

I assume part of the problem is that I forgot some of my usage skills.
Please help.

Sorry guys, problem solved.
No sure exactly why and how - I opened a new window and tried several times until the esptoolpy was installed correctly, followed by vscode restart and suddenly back to normal.