PlatformIO Community

error with web IDE

Error: Could not find a version that satisfies the requirement ‘~3.20501.2’ for your system ‘linux_x86_64’

In relation to what? What platform/framework/board? What’s in your platformio.ini file? It seems you’re on linux, but what distro?

so sorry about that, I just run https://github.com/platformio/platformio-remote-unit-testing-example code in codenvy.io , before that , I find the error with my ESP8266 arduino project which is ok in ubuntu18, there is no sample blink demo in Codenvy now.

That sounds like something you’ll need to take up with Codenvy, not PlatformIO. I also noticed their platformio-arduino-blink sample gives a 500 server error (500 https://codenvy.io).

I just ran a simple blink test project, and after finding out that Codenvy is running an older 3.x PlatformIO with their PlatformIO quickstart and upgrading that first, it successfully loaded all the requise toolchains and compilers, and built the project.

These are the packages it installed, and I don’t know what it was trying to install in your case as none of the version numbers match.

PlatformManager: Installing espressif8266
espressif8266 @ 2.2.3 has been successfully installed!
The platform 'espressif8266' has been successfully installed!
The rest of packages will be installed automatically depending on your build environment.
PackageManager: Installing toolchain-xtensa @ <3
toolchain-xtensa @ 2.40802.190218 has been successfully installed!
PackageManager: Installing tool-esptool @ <2
tool-esptool @ 1.413.0 has been successfully installed!
PackageManager: Installing tool-esptoolpy @ ~1.20600.0
tool-esptoolpy @ 1.20600.0 has been successfully installed!
PackageManager: Installing framework-arduinoespressif8266 @ ~2.20502.0
framework-arduinoespressif8266 @ 2.20502.0 has been successfully installed!