PlatformIO Community

Error while Creating Project using the PlatformIO

Hello Community,

I am working on the PlatformIO IDE to create ThreadX platformbased Quectel BG-96 project.
While creating it I am getting following error,

PIO Core Call Error: 
"The current working directory D:\\test\\PlatformIO\\bg96_test will be used for the project.
\n\r
\nThe next files/directories have been created in D:\\test\\PlatformIO\\bg96_test\ninclude - Put project header files here
\nlib - Put here project specific (private) libraries\nsrc - Put project source files here
\nplatformio.ini - Project Configuration File
\n
\n
\nError: Processing bg96 (platform: quectel; board: bg96; framework: threadx)
\n-------------------------------------------------------------------------------
\nCorePackageManager: Installing tool-scons @ ~2.20501.7
\ntool-scons @ 2.20501.190826 has been successfully installed!
\nVerbose mode can be enabled via `-v, --verbose` option
\n<<<<<<<<<<<< QUECTEL BG96 MODULE 2018 Georgi Angelov >>>>>>>>>>>>
\nCONFIGURATION: https://docs.platformio.org/page/boards/quectel/bg96.html
\nPLATFORM: Quectel 2.0.14 #adb27bc > Quectel BG96 module
\nHARDWARE: ARM, MDM9206 1200MHz, 3.00MB RAM, 3.00MB Flash
\nDEBUG: Current (uart) On-board (uart)
\nPACKAGES: framework-quectel fc4089a, toolchain-gccarmnoneeabi 1.70201.0 (7.2.1)
\n File \"C:\\users\\embed\\.platformio\\platforms\\quectel\\builder\\frameworks\\QDL.py\", line 122
\n
\nSyntaxError: Non-ASCII character '\\xd0' in file C:\\users\\embed\\.platformio\\platforms\\quectel\\builder\\frameworks\\QDL.py on line 122, but no encoding declared; see http://python.org/dev/peps/pep-0263/ for details
\n
\n========================= [FAILED] Took 10.65 seconds ========================="

will you please help me to solve this problem?

Regards,
Shiv Patil.

You have the actual error there at the end of the log…

If this is the source for the file, it’s saying that this line isn’t liked. Don’t ask me how or why, but it appears the ‘oo’ in footer are unicode text, which is invalid, hence the error.
image

If, like python, the file is read as ANSI only encoding (unless told otherwise), it looks like this! :open_mouth:
image

Edit: In case it wasn’t obvious (as I thought it was when I wrote this earlier), the solution is to edit that file locally, type in normal ‘oo’ for footer, and re-save the file, ensuring that it’s not UTF-8 formatted if your editor gives you that option. I can submit a PR to get file fixed, but I don’t know how active that repo is.

Edit 2: It’s been accepted already, so is present in the current master of that repo :slight_smile: