Error: unable to open ftdi device with vid 15ba, pid 002a, description 'Olimex OpenOCD JTAG ARM-USB-TINY-H', serial '*' at bus location '*'

Hi, I cant upload the example of “Hello World”… My 99-platformio-udev.rules : SUBSYSTEMS==“usb”,ATTRS{idVendor}==“15ba”,ATTRS{idProduct}==“002a”,MODE=“0666”, GROUP=“estibaliz”

Can anyone help me please? Thanks :slight_smile:
Captura de pantalla de 2020-04-29 05-39-27

What’s the output of


on the system?

Hi Maximilian,

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 006: ID 04f3:0903 Elan Microelectronics Corp. ELAN:Fingerprint
Bus 001 Device 005: ID 8087:0a2b Intel Corp.
Bus 001 Device 004: ID 13d3:5694 IMC Networks USB2.0 HD UVC WebCam
Bus 001 Device 010: ID 15ba:002a Olimex Ltd. ARM-USB-TINY-H JTAG interface
Bus 001 Device 009: ID 15ba:002b Olimex Ltd. ARM-USB-OCD-H JTAG+RS232
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Well if “Olimex Ltd. ARM-USB-TINY-H JTAG interface” is the description string and Openocd is searching for “Olimex OpenOCD JTAG ARM-USB-TINY-H” there will be a mismatch. Or you selected the wrong upload mechanism.

By name it sounds like the olimex-jtag-tiny or olimex-arm-usb-tiny-h might be used. Can you try both of these options as upload_tool and debug_tool and post the error messages, if any?

Hm well actually it might either be a openocd driver problem or a permission problem. Why did you modify the udev rules to explicitly include your group? It already contains

# Olimex probes
ATTRS{idVendor}=="15ba", MODE="0666", ENV{ID_MM_DEVICE_IGNORE}="1", ENV{ID_MM_PORT_IGNORE}="1"

which should be good. Check that you have the most recent udev rules (FAQ).

I also think it wouldn’t hurt if you installed the FTDI drivers per the manual, aka doing sudo apt-get install libftdi-dev libftdi1.

The same problem :frowning:

Then try and revert back to olimex-arm-usb-ocd-h and follow the udev and driver install above. Udev rules are not applied until a reboot is done, so do that, too.

I tried that, and now, again, same problem, I dont know what is happening :sleepy:

So you are now using olimex-arm-usb-ocd-h, have the original PlatformIO udev rules, you restarted the computer and it still does not work?

If it’s a permission problem, try executing VSCode as root. See permissions - How to run Visual Studio Code as root - Ask Ubuntu (sudo code --user-data-dir="~/.vscode-root").

Same problem. I tried it with W10 and Zadig, and same…

  • At what link did you buy your debug probe?
  • Did you also try all the available olimex-* combinations shown in PlatformIO?
  • in the windows device manager, what device name does it show for the Olimex devices (2 of them)