PlatformIO Community

Error trying to register library

I’m getting an error trying to register this library of mine:

Here is the error:

Error: Could not parse manifest -> Expecting value: line 7 column 1 (char 6)

I’ve spent several hours investigating this with no success and I’ve checked library.json for validity, checked the validity of library dependencies and searched everywhere for similar problem reports. I can change the order of the lines in library.json and I still get the exact same error so it must be a subtle problem. Or perhaps I can’t see the forest for the trees :slight_smile:

Any help with this would be appreciated!

What is your pio register command?

Ahh well, the most probably cause is that you’re pointing the register command to https://github.com/RocketManRC/u-blox-m8/blob/master/library.json, which is the Github UI page for the file, but not the raw file itself. The HTML page starts with 7 newlines and then some HTML code, so that’s not a valid JSON.

You have to register it as

pio lib register "https://raw.githubusercontent.com/RocketManRC/u-blox-m8/master/library.json"
1 Like

Yes that worked and the error makes sense now in hind sight.

Thanks so much!