Error: PlatformIO: Terminal service is not registered

I saw that my Atom was broken.

Did an update of all packages and now I can’t manage to open the PlatformIO Atom Terminal.

I removed completely all the platformio packages and reinstalled the platformio-ide package.

Still getting this error.

I am running on macOs.

Did anybody else have the same issue?

I tried this Terminal not working, only has flashing cursor - #7 by ivankravets but with no success.

I will try to use the core

Have you updated your atom recently? Maybe it is the cause of the problem.

After that I rebuilt that package and now works.

I did update the atom cause it was throwing some really weird errors. I think related to the scroll bar…

Thanks I will look into it.

It’s…problematic…if it’s “broken” with an Atom update, folks. Seriously.

1 Like

Worse, gang…it WAS working as of Friday. NO updates on my part there. It’s not “just” due to updates.

Same issue here. Removed all platformio packages, restarted, reinstalled, etc - same error:

PlatformIO: Terminal service is not registered.
‘Make sure that “platformio-ide-terminal” package is installed and activated.’

I can run ‘platformio’ in terminal just fine, just when selecting things like ‘Update platforms, packages and libraries’ from the menu it fails with that error. Rebuilding all platformio packages also didn’t help.

~ ❯❯❯ apm rebuild platform-ide-terminal
Rebuilding modules ✓
~ ❯❯❯ apm rebuild platform-ide
Rebuilding modules ✓
~ ❯❯❯ apm rebuild platform-ide-debugger
Rebuilding modules ✓

apm ls
├── platformio-ide@2.0.0-beta.8
├── platformio-ide-debugger@1.2.3
├── platformio-ide-terminal@2.5.5

Same here.

Did uninstall-reinstall everything (from Terminal package only to the whole Atom & PlatformIO), but nothing solved the problem.

Older thread recommended to install GCC which I did but did not help.

I didn’t use Platform-IO for a few days until today so I’m not sure since when it stopped working but I believe some auto-update got it broken as it used to work perfectly before.

MacOS Sierra 10.12.3
Atom 1.19.1 x64
PlatformIO 2.0.0-beta.8
Core 3.5.0a4
platformio-ide-terminal 2.5.5


I’m new to that kind of stuff and I had the same problem.

Take a look on the bottom right side … there is a bug-icon, click on it and choose “rebuild packages”, then restart atom and everything should be fine.

Solution found at: PlatformIO: Terminal service is not registered · Issue #196 · platformio/platformio-atom-ide · GitHub


Solved my problem, thanks !

I read it as well that we had to rebuild the packages but couldn’t find how to do it :slight_smile:
Seems silly now, but not obvious to me initially.

1 Like