Error: No such command "device"


I have just installed PlatformIO trying to use this software instead of INO.
Though, when I run the command: platformio device list I get the following output:

_Usage: platformio [OPTIONS] COMMAND [ARGS]..._
_Error: No such command "device"_

My platformio version is: 3.3.0a7
Has someone had similar problems?

Thank you.

How did you install PIO? what do you see with pio --version?

It was installed by following this tutorial:

  1. use: pip install -U platformio
  2. then python -c "$(curl -fsSL"

This is the result of the command pio --version:

pi@raspberrypi /home/platformio/temp-humid $ pio --version
PlatformIO, version 3.3.0a7

I can’t reproduce this issue. Could you try?

  1. pip uninstall platformio
  2. pip install -U platformio

I have uninstalled and installed with the commands provided, though when I ran again: **pio device list** I got the same No such command “device” error.

Note: I had to use sudo for those commands as without it I got “Permission denied errors”.
Note: The version was changed: from 3.3.0a7 (initially) to 3.2.1 (current version).

Please DON’T USE sudo. Try sudo rm -r ~/.platformio and run pio device list without sudo

sudo rm -r ~/.platformio
and after
pio device list (without sudo)
but still same error.

Should I have also uninstalled and reinstalled pio?
[Update] : I have also reinstalled pio after that but still no success

What is your Python? python --version?


pi@raspberrypi ~ $ python --version
Python 2.7.3

Has anyone solved this problem. I just updated to Platformio 2.0 on a Mac and am getting this same error when trying to open a serial port.