PlatformIO Community

Error: Multiple requests to rebuild the project

I’ve been away almost a year. I see some changes, but this is a problem I had way back in 2020/2021.

“Error: Multiple requests to rebuild the project”
It doesn’t seem to matter which project it is. None of today’s rebuild request files are open. They appear to be in the workspace.
It looks like PIO scans my projects folder and tells me there are multiple rebuild requests.

What’s this about? It happens a lot- constantly.
Can it go away?

Hi Joe, how are you doing?

I had a look for the error message you are seeing, is “https://github.com/platformio/platformio-vscode-ide/issues/2363” any use?

Cheers,
Norm.

Thanks Norm,
Doesn’t really help. I looked at this GitHub page.

There is a .ini file open, but I haven’t edited it at all.

This starts happening as soon as I open VSCode, whether there’s an open file or not. Seems like it’s just walking the entries in my workspace, but I’m not sure all the programs it’s rebuilding are in the workspace. Assume so.

I don’t have antivirus turned on. All my email comes in on Yahoo, and I never open anything fishy.

I suspect that VSCode is perhaps stuck somewhere. But I’m not sure. Helpful? Me? Probably not!

I’m not sure how that message is generated, have you tried shutting down everything, creating a new folder and copying only your ini and code files over – with the usual PlatformIO folders of course.

Then open the folder, file->open folder, in VSCode. As a new project it shouldn’t have any detritus perhaps left behind by an abandoned compile or similar.

Then see if the error occurs when you do what you do the see the error.

Cheers,
Norm.

Thank you for the link. That worked for me.

1 Like

Please check your platformio.ini, do you see any extra_scripts entries?

Thanks.
No, nothing like that.
This box pops up regardless of open programs.
I removed all files from the workspace, but I couldn’t resist putting a few back to fiddle.
I’ll repeat the exercise to see if the box appears with nothing in the workspace.

This is the (truncated) message:

(Edited by NormanDunbar, moderator, to format as code to resolve missing characters after backslashes.)

Error: Multiple requests to rebuild the project "Dashboard_Receiver_ESPNow_DOIT" index have been received! 
Automatic index rebuilding process has been terminated for 10 minutes. 
at A.value (c:\Users\joema\.vscode\extensions\platformio.platformio-ide-2.4.0\node_modules\platformio-node-helpers\dist\index.js:1:785147) 
at A.value (c:\Users\joema\.vscode\extensions\platformio.platformio-ide-2.4.0\node_modules\platformio-node-helpers\dist\index.js:1:787205) 
at A.value (c:\Users\joema\.vscode\extensions\platformio.platformio-ide-2.4.0\node_modules\platformio-node-helpers\dist\index.js:1:789041) 
at c:\Users\joema\.vscode\extensions\platformio.platformio-ide-2.4.0\node_modules\platformio-node-hel...

Sorry, didn’t think the ``` applied here.

The workspace is empty and no files are open. I haven’t seen the error box. I’ll leave it as is for a while, then add a folder to the workspace.

I added a folder to the workspace and waited a while. Then I opened a .cpp file, waited.

I cleaned it and hit the upload button, and the error box came back.
Multiple requests…