PlatformIO Community

Error: Multiple requests to build persistent error

I get Automatic index rebuilding process has been terminated for 10 minutes.
Appearing on all projects all of the time.

I have seen perhaps half a dozen posts related to the issue but I haven’t seen a resolution. Or haven’t understood the resolution.

I have vscode and platformio, git install (no other plugins) on three machines; win10, win11 and mint 20. I only see this issue on my main win10 box.

I tried uninstalling and reinstalling pio, etc. whatever it is persists.

Error: Multiple requests to rebuild the project "ttgo-battery-mon" index have been received!
Automatic index rebuilding process has been terminated for 10 minutes.
	at A.value (c:\Users\james\.vscode\extensions\platformio.platformio-ide-2.4.3\node_modules\platformio-node-helpers\dist\index.js:1:790605).....

And yes, have seen this post.

I have created a completely blank project with no libraries and it doesn’t seem to happen. But there are no 3rd party tools that might mess with the lib_deps folder as specified above.

I presume if its antivirus I’d need to basically exclude my entire project root folder? I’ll give that a go. [edit] its already excluded.

I have the same problem. Started when Visual Code updated to April 2022 (version 1.67). Before that, no problems.

1 Like

Same here, my release is 1.67.2. Bad instructions how to solve.
Any help is appreciated, it’s anoiing.

Problem is still not resolved. Once it starts cant really get rid of it. Does seem to be project dependent.

Fixed in PlatformIO Core 6.0.2. Please open PlatformIO Core CLI and type pio upgrade.

I was away when you posted this, I tried the upgrade and I think its borked my installation entirely.

  File "c:\users\james\.platformio\penv\lib\site-packages\pip\_internal\locations\_sysconfig.py", line 8, in <module>
    from pip._internal.exceptions import InvalidSchemeCombination, UserInstallationInvalid
ImportError: cannot import name 'InvalidSchemeCombination' from 'pip._internal.exceptions' (c:\users\james\.platformio\penv\lib\site-packages\pip\_internal\exceptions.py)


* Upgrade using `pip install -U platformio`
* Try different installation/upgrading steps:
  https://docs.platformio.org/page/installation.html

I tried the ‘different’ steps also not working. So maybe the simplest is to just uninstall and re-install. I’ll try that. I don’t really know what I would lose if anything.

ok that did nothing. The core remains old. Not really sure what to do now.

Please remove this folder and restart VSCode.

I actually renamed the entire tree .platformio. Then I went around it circles a bit because it said it was already installing but eventually after installing and uninstalling I got it working.

I checked a couple of my projects still build and it did pick up a few things it wanted to install and the builds seemed to take a bit longer than they used to but successful.

(it would probably work better if I wasn’t running 4 other vms.)