Error in the display of PlatformIO Home


#1

Hello,
i have some trouble with the display of the PlatformIO page… it all lists without proper positioning and i cannot select the boards…
it started after the latest PlatformIO IDE update.
Which information should i add ?
best,
Sylvain


#2

Do you use the latest Atom and PlatformIO IDE for Atom? If yes, please open PIO IDE Terminal and type pio update. Restart Atom. Does it work now?


#3

ooh, i’m getting this message :


Obsolete PIO Core v3.5.1 is used (previous was 3.5.2rc3)
Please remove multiple PIO Cores from a system:
http://docs.platformio.org/page/faq.html#multiple-pio-cores-in-a-system


i tried uninstalling and reinstalling PlatformIO from Atom but that didnt seem enough…


#4

Please remove all PIO Cores from a system.


#5

it keeps on reinstalling 3.5.1 each time i launch it ;
cannot access Platformio > Settings > Platformio IDE ( it just doesnt open the settings windows )


#6

Please update PIO IDE extension to 2.1.2 version. Does it work now?


#7

i could stop the constant reinstallation by uninstalling and reinstalling Platform IO and Python 2.7.4
and these options
OFF : automatically update Platform IDE
OFF : use platform development IDE
Use Built-in platform Core
ON : use development platform Core

current : is PlatformIO 3.5.2rc4

i did the upgrade to PIO IDE 2.1.2 right now. i can work with the editor, build and access settings of Platform,
but Platform Home still looks bad :


#8

Please open PlatformIO IDE Terminal and type

pio home

PIO Home should be opened in your standalone browser. Do you see any errors in console?


#9

I think those are two different issues. If you are not able to access the settings due to the re-install loop you can edit PIO_CORE_MIN_VERSION in config.js to your current version. From there you can follow http://docs.platformio.org/page/faq.html#multiple-pio-cores-in-a-system without reinstalling anything.


#10

the re-install issue is indeed solved, but i keep having the Home page in a strange way.
tried installing Safari thinking it was an issue with Java in Chrome, but nothing changes.
it wont open through pio home


#11

back to this topic since i need to use the Home page…

this is what i can see as warnings in Console after doing pio home :

(index):39 Resource interpreted as Stylesheet but transferred with MIME type application/x-css: “http://127.0.0.1:8008/themes/platformio-dark.css”.
(anonymous) @ (index):39

28c486a994ab65f53b53c.min.js:39 autoPlay is triggered more than once
r.autoPlay @ 8c486a994ab65f53b53c.min.js:39
(anonymous) @ 8c486a994ab65f53b53c.min.js:39
mt @ 8c486a994ab65f53b53c.min.js:25
commitLifeCycles @ 8c486a994ab65f53b53c.min.js:25
E @ 8c486a994ab65f53b53c.min.js:25
_ @ 8c486a994ab65f53b53c.min.js:25
b @ 8c486a994ab65f53b53c.min.js:25
v @ 8c486a994ab65f53b53c.min.js:25
m @ 8c486a994ab65f53b53c.min.js:25
c @ 8c486a994ab65f53b53c.min.js:25
enqueueSetState @ 8c486a994ab65f53b53c.min.js:25
a.setState @ 8c486a994ab65f53b53c.min.js:25
r.updateState @ 8c486a994ab65f53b53c.min.js:39
r.onWindowResized @ 8c486a994ab65f53b53c.min.js:39
(anonymous) @ 8c486a994ab65f53b53c.min.js:39

8c486a994ab65f53b53c.min.js:39 autoPlay is triggered more than once
r.autoPlay @ 8c486a994ab65f53b53c.min.js:39
(anonymous) @ 8c486a994ab65f53b53c.min.js:39
mt @ 8c486a994ab65f53b53c.min.js:25
commitLifeCycles @ 8c486a994ab65f53b53c.min.js:25
E @ 8c486a994ab65f53b53c.min.js:25
_ @ 8c486a994ab65f53b53c.min.js:25
b @ 8c486a994ab65f53b53c.min.js:25
v @ 8c486a994ab65f53b53c.min.js:25
m @ 8c486a994ab65f53b53c.min.js:25
c @ 8c486a994ab65f53b53c.min.js:25
enqueueSetState @ 8c486a994ab65f53b53c.min.js:25
a.setState @ 8c486a994ab65f53b53c.min.js:25
r.updateState @ 8c486a994ab65f53b53c.min.js:39
r.onWindowResized @ 8c486a994ab65f53b53c.min.js:39
a @ 8c486a994ab65f53b53c.min.js:39
load (async)
(anonymous) @ 8c486a994ab65f53b53c.min.js:39
r.checkImagesLoad @ 8c486a994ab65f53b53c.min.js:39
r.componentDidUpdate @ 8c486a994ab65f53b53c.min.js:39
commitLifeCycles @ 8c486a994ab65f53b53c.min.js:25
E @ 8c486a994ab65f53b53c.min.js:25
_ @ 8c486a994ab65f53b53c.min.js:25
b @ 8c486a994ab65f53b53c.min.js:25
v @ 8c486a994ab65f53b53c.min.js:25
m @ 8c486a994ab65f53b53c.min.js:25
c @ 8c486a994ab65f53b53c.min.js:25
enqueueSetState @ 8c486a994ab65f53b53c.min.js:25
a.setState @ 8c486a994ab65f53b53c.min.js:25
i.onStateChange @ 8c486a994ab65f53b53c.min.js:6
notify @ 8c486a994ab65f53b53c.min.js:6
e.notifyNestedSubs @ 8c486a994ab65f53b53c.min.js:6
i.onStateChange @ 8c486a994ab65f53b53c.min.js:6
s @ 8c486a994ab65f53b53c.min.js:6
(anonymous) @ 8c486a994ab65f53b53c.min.js:6
(anonymous) @ 8c486a994ab65f53b53c.min.js:17
(anonymous) @ 8c486a994ab65f53b53c.min.js:33
dispatch @ 8c486a994ab65f53b53c.min.js:6
(anonymous) @ 8c486a994ab65f53b53c.min.js:6
(anonymous) @ 8c486a994ab65f53b53c.min.js:17
r @ 8c486a994ab65f53b53c.min.js:17
s @ 8c486a994ab65f53b53c.min.js:17
a @ 8c486a994ab65f53b53c.min.js:17
(anonymous) @ 8c486a994ab65f53b53c.min.js:6
t @ 8c486a994ab65f53b53c.min.js:6
(anonymous) @ 8c486a994ab65f53b53c.min.js:17
(anonymous) @ 8c486a994ab65f53b53c.min.js:33
dispatch @ 8c486a994ab65f53b53c.min.js:6
o.onmessage @ 8c486a994ab65f53b53c.min.js:6
r.dispatchEvent @ 8c486a994ab65f53b53c.min.js:17
(anonymous) @ 8c486a994ab65f53b53c.min.js:33
r._transportMessage @ 8c486a994ab65f53b53c.min.js:33
r.emit @ 8c486a994ab65f53b53c.min.js:6
ws.onmessage @ 8c486a994ab65f53b53c.min.js:33


#12

and this is the look of it :


#13

Does it work now? Please run pio upgrade.