PlatformIO Community

Error: Could not find the package with 'ststm32 @ 0.1.0' requirements for your system 'windows_amd64'

Hi there,
I need to use mbed framework v1.121.1 for an old project. When i tried to install ststm32@0.1.0, i got Error: Could not find the package with ‘ststm32 @ 0.1.0’ requirements for your system ‘windows_amd64’ message. How can i compile code for mbed framework v1.121.1?

Here versions that I tried.

  • Python version : 2.7.15
  • Platformio version : 3.0.0 (also 5.0.0)

cmOldVersion_2

Thanks & Regards

Where did you get this?

  1. Please uninstall ALL PlatformIO Cores from the system.
  2. Install the latest PlatformIO Core 5.2.4
  3. Check available versions of the development platform