Error Cloning Git Project ("authentication" ...but probably not really)

When attempting to clone a repo from GitHub, using PlatformIO IDE’s Clone Git Project, I’m greeted with the following error in the git log:

**> git clone /Users/ts/Documents/PlatformIO/Projects/oled3 --progress Cloning into '/Users/ts/Documents/PlatformIO/Projects/oled3'... remote: Repository not found. fatal: Authentication failed for ''**

This does not appear to be related to the vccode/gihub authentication handoff, nor does it appear to be related to the repo on github, as the process does work when tested on a different (Windows) machine.

Any thoughts on what I might try next?

That page does not exist. Which project references it?

Thanks Max.

I’ve tried the same PIO Clone Git Project command on another machine and it worked flawlessly, so it’s not related to the repo on GitHub (I’m sure you would see the same if it were still there). It’s somehow related to the state of this particular instance of PIO on this machine.

I was just hoping for some ideas on how I might go about digging into some kind of troubleshooting…

Well it’s definitely a private repo…


You’re seeing things through the lens of being authenticated with your account – the git program on the computer it’s not working with does probably not have the required login credentials (most likely a private & public key pair) and thus cloning fails.

Double checks how you’ve set up authentication on the working computer and confirms it’s the same on the non-working computer.

Thanks again, very much, Max.

I was authenticating through “Settings Sync” within VS Code via the little profile icon in the lower left of the VSC UI. (Switching it on opens a GH authentication page, which shows success before redirecting back to VS Code, which showed “Settings Sync is on”)

I have no idea what the problem was (I’m sure it was me, somehow) but I reinstalled and tried again, and everything now works. Sorry to have taken your time.