Error ATOM- PlatformIO, I can´t install PlatformIO

i can´t install IDE platformIO:
nstallation Manager

Error: Traceback (most recent call last): File “C:\Users\fugit.platformio.cache\tmp.piocore-installer-i95hv_x5\tmpx6nuz5cx\\pioinstaller\”, line 170, in find_compatible_pythons File “C:\Users\fugit\AppData\Local\Programs\Python\Python310\lib\”, line 420, in check_output return run(*popenargs, stdout=PIPE, timeout=timeout, check=True, File “C:\Users\fugit\AppData\Local\Programs\Python\Python310\lib\”, line 524, in run raise CalledProcessError(retcode, process.args, subprocess.CalledProcessError: Command ‘[‘C:\Users\fugit\AppData\Local\Microsoft\WindowsApps\python3.exe’, ‘C:\Users\fugit.platformio.cache\tmp\’, ‘–no-shutdown-piohome’, ‘check’, ‘python’]’ returned non-zero exit status 9009.

During handling of the above exception, another exception occurred:

Traceback (most recent call last): File “C:\Users\fugit.platformio.cache\tmp\”, line 69, in main() File “C:\Users\fugit.platformio.cache\tmp\”, line 61, in main bootstrap() File “C:\Users\fugit.platformio.cache\tmp\”, line 47, in bootstrap pioinstaller.main.main() File “C:\Users\fugit.platformio.cache\tmp.piocore-installer-i95hv_x5\tmpx6nuz5cx\\”, line 122, in main File “C:\Users\fugit.platformio.cache\tmp.piocore-installer-i95hv_x5\tmpx6nuz5cx\\click\”, line 829, in call File “C:\Users\fugit.platformio.cache\tmp.piocore-installer-i95hv_x5\tmpx6nuz5cx\\click\”, line 782, in main File “C:\Users\fugit.platformio.cache\tmp.piocore-installer-i95hv_x5\tmpx6nuz5cx\\click\”, line 1236, in invoke File “C:\Users\fugit.platformio.cache\tmp.piocore-installer-i95hv_x5\tmpx6nuz5cx\\click\”, line 1066, in invoke File “C:\Users\fugit.platformio.cache\tmp.piocore-installer-i95hv_x5\tmpx6nuz5cx\\click\”, line 610, in invoke File “C:\Users\fugit.platformio.cache\tmp.piocore-installer-i95hv_x5\tmpx6nuz5cx\\click\”, line 21, in new_func File “C:\Users\fugit.platformio.cache\tmp.piocore-installer-i95hv_x5\tmpx6nuz5cx\\”, line 52, in cli File “C:\Users\fugit.platformio.cache\tmp.piocore-installer-i95hv_x5\tmpx6nuz5cx\\pioinstaller\”, line 72, in install_platformio_core File “C:\Users\fugit.platformio.cache\tmp.piocore-installer-i95hv_x5\tmpx6nuz5cx\\pioinstaller\”, line 52, in create_core_penv File “C:\Users\fugit.platformio.cache\tmp.piocore-installer-i95hv_x5\tmpx6nuz5cx\\pioinstaller\”, line 191, in find_compatible_pythons UnboundLocalError: local variable ‘error’ referenced before assignment → Installer version: 0.3.5 Platform: Windows-10 Python version: 3.10.2 (tags/v3.10.2:a58ebcc, Jan 17 2022, 14:12:15) [MSC v.1929 64 bit (AMD64)] Python path: C:\Users\fugit\AppData\Local\Programs\Python\Python310\python.exe Creating a virtual environment at C:\Users\fugit.platformio\penv

The Microsoft store python3 has caused some problems in the pat, can you install Python from the official website (e.g. Python 3.9.8), put that Python as the first thing in your PATH and retry?

Hi maxgerardt
I already tried installing version 3.10 and it keeps showing that error.
It is worth mentioning that this error is inside ATOM when I install PlatformIO.

Now that you’ve installed the official Python version, does it keep referencing the Microsoft Store Python version in the error message? Then it may not be in the top of the PATH.

Yes, it keeps throwing that error.
Might you help me?
I say, which route is the one you ask for?
Where should I save the installation?

It doesn’t matter where the (official) python installation is as long as it’s in the path.

You may want to file an issue in GitHub - platformio/platformio-atom-ide: PlatformIO IDE for Atom: The next generation integrated development environment for IoT, or use the recommended VSCode IDE. Atom support is considered legacy.

atom core (1 deprecation)

  • Use require("electron").shell instead of require("shell")

Object. - C:\Users\fugit\AppData\Local\atom\app-1.58.0\resources\app.asar\exports\shell.js:4:6

Object. - C:\Users\fugit\AppData\Local\atom\app-1.58.0\resources\app.asar\exports\shell.js:9:3

Module._compile - :11:149891

Object…js - :11:153485

Module.load - internal/modules/cjs/loader.js:815:32

Module._load - internal/modules/cjs/loader.js:727:14

that appears to me because of the error

this solved my problem