Error after trying to install PlatformIO IDE extension in VSC

Installing PlatformIO IDE…

It may take a few minutes depending on your connection speed

Please do not close this window and do not open other folders until this process is completed.

Debugging information is available via VSCode > Help > Toggle Developer Tools > Console.

Failed to install PlatformIO IDE.

Error: TypeError [ERR_INVALID_ARG_TYPE]: The “path” argument must be of type string. Received null at c:\Users\Charl.vscode\extensions\platformio.platformio-ide-2.3.3\node_modules\platformio-node-helpers\dist\index.js:1:771390 at a (c:\Users\Charl.vscode\extensions\platformio.platformio-ide-2.3.3\node_modules\platformio-node-helpers\dist\index.js:1:771284) at w (c:\Users\Charl.vscode\extensions\platformio.platformio-ide-2.3.3\node_modules\platformio-node-helpers\dist\index.js:1:771035) at u (c:\Users\Charl.vscode\extensions\platformio.platformio-ide-2.3.3\node_modules\platformio-node-helpers\dist\index.js:1:770559) at c:\Users\Charl.vscode\extensions\platformio.platformio-ide-2.3.3…

This is the information i have right now, i’m new to coding so i don’t know what more to give so please guide me

Please report that to Issues · platformio/platformio-vscode-ide · GitHub for @ivankravets.

I have resolved this issue by uninstalling VSC and reinstalling fresh without extensions. Installing PlatformIO this time prompted me to install the latest version of Python.

I had this problem. By installing the latest Python on my windows and restarting the VSC, the problem solved.
hope this is helpful for others.

I solved this by ticking on “add path” on python installation

Also see PlatformIO errors while trying to install · Issue #2703 · platformio/platformio-vscode-ide · GitHub, the solutions have been discussed there.

Have tried to install this multiple times on my Win 10 machine and have tried all the solutions listed here.
This includes a fresh uninstall/reinstall of VSCode, installing Python, disabling firewall and antivirus. Need some help!

But that Total Defense Interneset Security Suite is still popping up in the error, so it doesn’t seem disabled.

I don’t even have that installed. All I have is the Windows Defender and Windows Firewall.

So the folder C:\Program Files\Total Defense does not exist or is empty?


Hi, I have this problem after a short time not using VS code.
It used to work on my VS Code, but now just came to this.

I tried to reinstall VS Code and also reinstall PlatformIO on VS Code, but doesn’t work

Could anyone help!!!