PlatformIO Community

Eclipse integration Serial strangeness

Hi, I’ve been using VSCode with PIO integration, and that’s been OK. But when I heard there was integration with Eclipse, I wanted to switch. So I downloaded Eclipse and integrated PIO with it. Everything seemed fine, until I tried using Serial statements in the code.

I have a short program to control LED strips, and was getting unexpected behavior from that program. Using the Eclipse environment, I threw some serial output statements in the code to try and locate the problem, and uploaded the new code to the board. Then I searched the IDE interface…and could find no option to open a serial monitor within Eclipse (I sort of expected there to be one since that is well-integrated with VSCode). Giving up on the IDE for this, I tried using the PIO monitor option, along with running miniterm.py directly, from a bash prompt. Both of those seemed to connect to the serial port OK, but neither gave any output. It was then I noticed that the LED on the board was not flashing, as it usually does when serial I/O is happening.

After trying various remedies with no results, I decided to quit Eclipse and load the project back into the VSCode environment. I did another build/upload, opened the serial monitor and it worked. In particular, I saw that the board LED was now flashing as expected.

So it seems that somehow, within the Eclipse environment, despite the fact that the code works at a base level, any Serial statements I include seem to have no effect. But when building and uploading the exact same code from VSCode, Serial calls work as expected.

I suspect that I must have something misconfigured in the Eclipse environment, but have no idea where to look.

Thanks for any suggestions!

Since PlatformIO just generates Eclipse project files, it doesn’t add a custom extension for a serial monitor. There are however 3rd-party extensions available.

Either you are not connected to the correct serial port (settable via monitor_port, docs), haven’t set the right speed / baud rate (monitor_speed) or the board is genuinely not sending UART data.

Can you show your full platformio.ini and the code you’re uploading to it? Are there any upload errors?

OK, I am baffled. In VSCode, I made a small test program to simply output serial text. As expected, it worked fine in VSCode. Then I loaded that into my Eclipse environment, rebuilt and uploaded. As NOT expected, that code works there too.

Thank you for your suggestions.