PlatformIO Community

Don't able to open platformio in VScode


#1

here you can see I installed PlatformIO in my VS code but don’t know to from where I can open it? I restarted VS code but didn’t see platformIO startup pop-ups

and also toolbar also are not there as shown in documentation of PIO

https://docs.platformio.org/en/latest/ide/vscode.html


^^^^^^^^^^^^^THIS IS THE MY PC SCREENSHOT^^^^^^^^^^^^

***help me if I had the wrong steps!!!


#2

Sounds like you did everything right.

Have a look in the output screen to see if there is anything under say extensions, or maybe on the terminal.

I see you have the python extension enabled also… it’s possible that’s conflicting with the pio bundled python. Might be worth disabling that and restarting VSCode, or even uninstalling the PIO extension and trying again if there’s nothing in the terminal or output logs.


#3

I reinstalled PIO and VScode 2-3 times but still, this problem was not solved. and I think so Python is a dependency of PIO as see in PIO dependence list {C++ /Python } this two is PIO dependency


#4

It is a dependency, but it doesn’t get installed as an extension - the PlatformIO pulls down the anaconda python runtime on Windows and uses it privately. I had no end of trouble with a seperately installed python install on Windows with PIO, but that was partly due to me instaling both 2.7 and 3.6 side by side, and then removing one, and using PIO/VSCode at the same time. My Linux install doesn’t seem to have any issues though, and I have the same Python VSCode extension installed there.

So, if you have the PIO extension uninstalled (I’m assuming you restart VSCode after doing that to make sure any final traces are removed) do you get a message when installing the PIO extension (in the terminal at the bottom) about restarting VSCode to continue? Wondering at what stage this is failing…


#5

still noting happen :frowning:


#6

So you don’t even get this far? Note that I deleted my %userprofile%\.platformio folder at the start there to ensure it was a fresh start.


#7

still not solved. I do every certain thing delete all the PIO and VScode file from everywhere in PC and reinstall the entire VScode and PIO and by following these two links

https://docs.platformio.org/en/latest/faq.html#install-python-interpreter

https://docs.platformio.org/en/latest/ide/vscode.html#quick-start

don’t know where I’m stuck :roll_eyes:


#8

Do you have some antivirus software installed? Can you temporary disable it?


#9

no I didn’t install any third party antivirus software in my computer I just enable my Windows Defender