DOIT-ESP32-DEVKIT-1 cannot open serial monitor

Hi, I would like to know why when I try to upload code to my esp32 on linux using the vscode platformio extension, it doesnt require me to hold down the “boot” button and I am unable to open the serial monitor. On windows, I am required to hold down the “boot” button on the esp32 when uploading new code to it, and I can open the serial monitor normally. I have installed the udev rules and had no problems with a sparkfun board I was previously using. I used this same board on linux about a year ago and it didnt behave like this. Can someone help me figure out whats wrong? The board I am using is the esp32doit-devkit-v1, I am using the Arduino framework and the baud rate is set correctly.

I don’t think thats a windows / linux problem!
Some Boards are missing a small 10nF capacitor between EN and GND.
One of my boards works perfectly on my Notebook, but not on my stationary PC.
Soldering a small cap solved the problem for my PC.

Hi! thank you for your answer, but I don’t think that’s the solution as i am able to read the serial output using picocom instead of the VSCode serial monitor. I’d like to use the VSCode serial monitor tho, as its one less terminal window open. Do you have any idea how i could make the VSCode serial monitor work? Is this even the right place to ask?

The capacitor is to solve the upload issue, not for the serial monitor.
See [SOLVED] Failed to connect to ESP32: Timed out waiting for packet header | Random Nerd Tutorials

For the serial monitor:
Check your platformio.ini for the monitor_port and monitor_speed settings.

I tried setting both the monitor_port and the monitor_speed. The serial console of VSCode still fails to open the serial port while picocom still works flawlessly. I have to note that picocom only works with the ‘-D ARDUINO_USB_MODE=1’ and ‘-D ARDUINO_USB_CDC_ON_BOOT=1’ build flags in the platformio.ini
I think it’s a problem with the VSCode serial monitor plugin. Are there any settings I should change on that part? Could this be some sort of permission issue? Again, I do not know if this is the right place to ask, as I don’t think it’s a platformio problem as I previously thought.

What Serial monitor do you use?

  • VS Code plugin
  • PlatformIO Monitor task

Settings like monitor_port and monitor_speed in the platformio.ini only applies to PlatformIO’s monitor task.

I was using the VS Code plugin, I didn’t know platformio had such a feature!
The monitor task works, I’ll be using that in the future :smiley:
Thank you for your help!

1 Like