PlatformIO Community

Debugging / Uploading & Connection / Setup

I’m trying to configure the PIO debugger to use Black Magic Probe for my Wio Lite MG126 and XIAO environments. These use the atmelsam platform and have SAMD21G ARM architecture. It’s been a month since I started trying.

This is my platformio.ini
image

I added the platform_packages line after reading this post

Then I got a git error when I tried to build
image

So I did what it said and installed the git client for windows but I’m getting the same message.

What else could it mean to install the git client? There are also vscode extensions but I’m trying not to introduce any more conflicts.

If this is a professional solutions forum I don’t know what to expect but I will pay for a solution. Send me a quote for consulting help because no one wants to touch this.

image

Hi, @kritischer,
I just compiled your project on my system (had to add references to Adafruit Zero DMA Library and SPI). It compiled flawlessly.
Are you sure, that your installation of the Git Client is correct, esp. if Git bash is in your path.
Git: Installing Git in PATH with GitHub client for Windows - Stack Overflow
Do you get an answer from Git when you enter git in a command window?

Thank you for the time to give some feedback. I had problems because
-Git path not added to %path% variable
-wrong version of bossac for the commands
-missing an offset for proper code uploading for Seeed boards

There’s always someone out there with a better way for everything but this worked for me

This is what solved my problem
platformio.ini
image

-Needed to install bossac 1.9.1

  • copied bossac.exe to %username%.platformio\packages\tool-bossac

-needed to make following change the upload_protocol == “sam-ba” section of main.py in %username%.platformio\platforms\atmelsam\builder to add the “-a” flag (1200baud reset) and make sure the offset got added… I’m not sure if it needs to be in there twice.
image

-removed hidden com ports and registry entries for all vid/pid of boards I had issues with
-turned off windows 10 driver signing and forced all of the seeedstudio inf to install but not sure if it was part of the solution

Pain points
-couldnt figure out how to update bossa within VScode/PIO
-couldn’t figure out how to install git client
-not sure if all of this could have been cleared up without changing main.py

Thanks for posting your results

After all the rabbit holes I’ve been down in the last month it’s the least I could do. Hopefully someone else doesn’t have to go through what I did.

Something else I forgot to mention is what when bossa 1.9 was installed it came with a usb driver. I think that has something to do with it too.

Even though I can upload it is being done over the USB native port so I’m happy about that but I always want more.