Could not initialize project PIO Core Call Error:

I got this error after the update and im not sure what to do.
Any help would be great.

\nObsolete PIO Core v4.0.3 is used (previous was 4.1.0)\nPlease remove multiple PIO Cores from a system:\n\n

Plus a wall of text after it



As the helptext says, it seems you have a seperate core installation and then one from your VSCod extension? The link walks you through disabling one of them

ok thanks ill try and work it out

I looked at that text and could not work out what to do :frowning: .
I was enjoying using platformio so i tried uninstalling both vscode and platformio and reinstalling it and i had the same problem as soon as i went to set up a new project. Is there a basic way to remedy this problem? :cry:

When you say ‘wall of text’ … do you mean the something like the following plus a successful compile, or was there actually some sort of error message?

Obsolete PIO Core v4.1.0 is used (previous was 4.1.1a1)
Please remove multiple PIO Cores from a system:

When you uninstalled platformio, did you delete the %userprofile%\.platformio folder? Removing that folder has a good chance of removing the error. It sounds like your issue occurred as part of a normal PIO upgrade (or did you downgrade from 4.1.0 to 4.0.3?). You could just delete the %userprofile%\.platformio\appstate.json (which is how PlatformIO knows a later version was installed at some point) but it would be better to let it do a clean reinstall.

1 Like

Thanks pfeerick that worked, i also deleted the vscode files just to make sure :smiley:

1 Like