PlatformIO Community

Could not find a version that satisfies the requirement

Hello guys,
I get following error if i start Platform io Home on Vscode:

Error: Error: Could not find a version that satisfies the requirement ‘~2.39.0’ for your system ‘windows_amd64’

at c:\Users\me\.vscode\extensions\platformio.platformio-ide-1.10.0\node_modules\platformio-node-helpers\dist\index.js:1:11965
at ChildProcess.d (c:\Users\me\.vscode\extensions\platformio.platformio-ide-1.10.0\node_modules\platformio-node-helpers\dist\index.js:1:8215)
at ChildProcess.emit (events.js:203:13)
at ChildProcess.cp.emit (c:\Users\me\.vscode\extensions\platformio.platformio-ide-1.10.0\node_modules\platformio-node-helpers\node_modules\cross-spawn\lib\enoent.js:34:29)
at maybeClose (internal/child_process.js:1021:16)
at Process.ChildProcess._handle.onexit (internal/child_process.js:283:5)
  • I revomed all platformio files in “Windows User/profiles”
  • I revomed any platformio vcode extentions
  • I reinstalled platformio and vscode.
    Everythink was helpless.

I hope anybody got the same issue and solved this already and can help me.

Finaly i Fix it. My Python Version was 3.9. I downgrade it on 3.8.0
Now i Can start Pio Home.

2 Likes