PlatformIO Community

Compile error. Marlin in vs code ant platformIO

Hey, when i compile marlin i get this message:

AssertionError: :File “C:\Users\Ole.platformio\penv\lib\site-packages\platformio\builder\main.py”, line 169: env.SConscript("$BUILD_SCRIPT")

File “C:\Users\Ole.platformio\packages\tool-scons\sconslocal4.0.1\SCons\Script\SConscript.py”, ine 598:return _SConscript(self.fs, *files,**subst_kw)

File “C:\Users\Ole.platformio\packages\tool-scons\scons-local-4.0.1\SCons\Scri\SConscript.py”, line 287:exec(compile(scriptdata, scriptname,‘exec’), call_stack[-1].globals)

File “C:\Users\Ole.platformio\platforms\ststm32\builder\main.py”, line 98: target_elf = env.BuildProgram()

File “C:\Users\Ole.platformio\packages\tool-scons\scons-local-4.0.1\SCons\Environment.py”, line 219:return self.method(*nargs, **kwargs)

File “C:\Users\Ole.platformio\penv\li\site-packages\platformio\builder\tools\platformio.py”, line 61:env.ProcessProgramDeps()

File “C:\Users\Ole
.platformio\packages\tool-scons\scons-local-4.0.1\SCons\Environment.py”, line 219:return self.method(*nargs, **kwargs)

File “C:\Users\Ole.platformio\penv\lib\site-packages\platformio\builder\tool\platformio.py”, line 127:env.BuildFrameworks(env.get(“PIOFRAMEWORK”))

File “C:\Users\Ole.platformio\packages\tool-scons\scons-local-4.0.1\SCons\Environment.py”, line 219:return self.method(*nargs, **kwargs)

File “C:\Users\Ole.platformio\penv\lib\site-packages\platformio\builder\tool\platformio.py”, line 339:env.ConvertInoToCpp()

File “C:\Users\Ole.platformio\package
s\tool-scons\scons-local-4.0.1\SCons\Environment.py”, line 219:return self.method(*nargs, **kwargs)

File"C:\Users\Ole.platformio\penv\lib\site-packages\platformio\builder\tools\piomisc.py", line 2
39:out_file = c.convert(ino_nodes)

File “C:\Users\Ole.platformio\penv\lib\site-packages\platformio\builder\tools\piomisc.py”, line 91:return self.process(contents)

File “C:\Users\Ole.platformio\penv\li\site-packages\platformio\builder\tools\piomisc.py”, line 112:assert self._gcc_preprocess(content, out_file)

[FAILED] Took 2.42 seconds
Environment bugfix-2.0.x> echo “done” >C:\Users\Ole\AppData\Local\Temp\ipc PS C:\Users\Ole\Down
loads\Ender3\Marlin-bugfix-2.0.x> 1 failed, 0 succeeded in 00:00:02.418

whats wrong here?

Can you please edit your post and replace the output without all the unnecessary line break? In it’s current form, it’s very difficult to help you.

thanks for the input. hope its easyer now.

It looks as if something goes wrong when the .ino file is converted to a .cpp file.

In order to be able to diagnoese it, can you:

  • post the platformio.ini file
  • post the .ino file
  • post the entire build log, preferably when building in verbose mode (pio run -v)