Compilation error that wasn't before


I’ve imported a Teensy Arduino sketch and worked with it error free for the last month. Since two days ago, I started getting one funny error:

error: narrowing conversion of '-2140930048' from 'int' to 'uint32_t {aka long unsigned int}' inside { } [- Wnarrowing] 0x00400005 | F01 }; // MUX[3] = 1, ADCM = 001, ADCS = 1 ^ *** [.pioenvs\teensylc\src\MAX2871.o] Error 1

It relates to the following piece of code:

//Setting temperature read and MUX readout uint32_t regInitValues[6] = { EN_INT | N_SET | F_SET | REG_0, CPL | CPT | PHASE | M_SET | REG_1, 0x00005E42 | LDF, 0xE8000013, 0x618160DC | DIVA, 0x00400005 | F01 };

This narrowing issue seems to originate from compiler itself and I found out on internet that it ought to be only a warning in latest compiler versions. Arduino IDE compiler doesn’t make any errors about it. So, is there a way to change compiler in Platformio to the one Arduino uses? Or is there a way to individually update Teensy package and corresponding compiler?

EDIT: Solved. The key was to set (uint32_t) before the value in any of used #defines.