Compilation error, Marlin

Hello, an error occurred while compiling Marlin for the Tronxy X5SA printer. I did everything according to the instructions as in the video ( Tronxy to Marlin Updated with new Procedure. - YouTube ).
Tried in Atom and VSCode

Error text:

Executing task in folder s3: C:\Users\admin.platformio\penv\Scripts\pio.exe run <

Processing chitu_f103 (platform: ststm32@~10.0; board: CHITU_F103; framework: arduino)

Platform Manager: ststm32 @ 10.0.1 is already installed
Error: Unknown development platform ‘PackageItem <path=C:\Users\admin.platformio\platforms\ststm32 metadata=PackageMetaData <type=platform name=ststm32 version=10.0.1 spec={‘owner’: ‘platformio’, ‘id’: 8020, ‘name’: ‘ststm32’, ‘requirements’: None, ‘url’: None}’
The terminal process “C:\Users\admin.platformio\penv\Scripts\pio.exe ‘run’” terminated with exit code: 1.

Terminal will be reused by tasks, press any key to close it.

Either your PlatformIO core is not up-to-date or you’re trying to compile an old Marlin option.

Can you


and retry?

Thanks. But it didn’t work out. I will try to do something with Marlin.

You can also try and remove all previous packages and platforms in case something weird was installed.

For that, remove all folders in C:\Users\admin\.platformio\packages\* and C:\Users\admin\.platformio\platforms\* and also C:\Users\admin\.platformio\.cache.

A clen version of all needed packages is redownloaded the next time you hit “Build”.

Thank you very much! It worked!))