Colors are wrong not working!

Hello I was working with platformio to develop esp8266 firmware, I tried to install the esp-idf extension but suddenly the colors in the code all changed to white! please help.


Hard to say anything without the full picture.

  • Is the source file you’re editing a .cpp, .c or a .ino file?
  • What is the full platformio.ini?
  • What is the list of extensions you have installed in VSCode?


  • My source files are .ino files
  • This is my platformio.ini with the extensions

You’re only showing 11 of your 17(!) installed extensions. I would also recommend to uninstall CMake extensions if you don’t need them, maybe they conflict with PlatformIO.

Try renaming to .cpp and converting accordingly?

Here are the rest of the extensions, it only allowed me to post 1 picture.

I was working on platformio for almost 6 or 7 months it was working fine. The only thing that happened is that I tried to install the esp-idf extension and then this happened.

I also disabled the CMake extension.

The “C++ Intellisense” by austin extension is known to conflict with PlatformIO, you should remove it. Also try disabling the “ESP-IDF” extension. (I think you mean CMake by this)?

I disabled all extensions i have on vs and still problem isn’t fixed

Are you working with a .ino file now or still .cpp?

im working with .ino always .ino

So do the colors come back when you rename the file to .cpp?

No, i renamed it to .cpp but still colors are the same

Does it change when you clock on the “Default …”


and instead select the esp12e environment in your project?

No, just tried now and still it doesn’t :frowning:

I removed most of my extensions and here are the left, with my .ini file

I don’t have any further ideas except reinstalling the PlatformIO extension. File an issue in Issues · platformio/platformio-vscode-ide · GitHub if it doesn’t work.

I found the solution… it was the theme i changed it so it changed the colors