CLion PlatformIO serial monitor - empty, no output, no error

Hi all, just upgraded CLion and I can’t get the Serial Monitor to work. I’m not seeing any error - it’s just that all the serial print statements that were working on previous version of CLion with old serial monitor plugin are now printing nothing.

So I’m missing some new setting in the ini file or something?

This is all I see in the terminal output.

Hard resetting via RTS pin…
— Terminal on COM9 | 115200 8-N-1
— Available filters and text transformations: colorize, debug, default, direct, esp32_exception_decoder, hexlify, log2file, nocontrol, printable, send_on_enter, time
— More details at Redirecting...
— Quit: Ctrl+C | Menu: Ctrl+T | Help: Ctrl+T followed by Ctrl+H
E (12044) wifi:Set status to INIT

this is my platformio.ini

platform = espressif32
board = lilygo-t7-s3
framework = arduino
upload_protocol = esptool
targets = upload
lib_deps =
monitor_speed = 115200

thanks, Kevin.

Well technically that’s a print output.

Have you ran the most minimal sketch to ensure it’s not a problem with your code?

#include <Arduino.h>

void setup() { Serial.begin(115200); }
void loop() { Serial.println("Hello"); delay(1000); }

Code hasn’t changed since it was working with the previous CLion serial monitor plugin and older version of PlatformIO (6.1.7) - confident that code is not the issue.

Also confident that if I create a new project with minimal sketch it will work fine.

The issue is some kind configuration that wasn’t set/migrated correctly when I updated PIO and CLion to use the new plugin.

The above sketch is the simplest way to tell if “the serial monitor is broken”, please test it out.

Together with a PlatformIO core update, there could have been a platform update for espressif32?

Ok - minimal sketch doesn’t work either - same thing, no error and no output.

I tried going back to my ESP8266 boards but now upload doesn’t work on those, I get the following error on both a brand new pio project with minimal sketch and also on a project that needed converting to the new pio plugin version.
“Error: Please specify upload_port for environment or use global --upload-port option.”

This is a custom board definition right? It’s not contained in here. What’s the content of your lilygo-t7-s3.json? Also what Platform: Espressif32 version is it outputting in the build log?

yes - json is from lillygo github

Previously I was using adafruit_feather_esp32s3_nopsram board since they’re both ESP32-S3s and that was working fine with upload and serial monitor

But I tried switching platformio.ini env back to adafruit_feather_esp32s3_nopsram board since I started this thread and that doesn’t work either,

Also strangely - I only saw that “E (12044) wifi:Set status to INIT” once - haven’t seen in any of many attempts since

Their board definition is screwed, they don’t define the macro for “The USB-CDC should be initialized as serial port” so it defaults to UART (which will log into nothing as there’s no USB-UART converter on the board).

They post-fixup this flunk in the platformio.ini with

interesting - so that build flags ini entry is not this part in the json?

“extra_flags”: [

I had that exact build flag ini entry when I had the platformio.ini set to the AdafruitFeatherS3 board and env because it wouldn’t work without it. As far as I can recall - upload wouldn’t work without it, never mind serial.

In any case - with the lilygo json instead, and the new pio plugin, it makes no difference whether that buildflag ini entry is there or not. In both cases upload works fine, serial monitor is empty.

pio version by the way is
pio --version
PlatformIO Core, version 6.1.11

monkey see monkey do
I copied the USB-CDC line from another json file to the lilygo one and now serial monitor is working!

Many thanks Max - now I just need to figure out what’s going on with my damn 8266 boards …

“extra_flags”: [

If it can’t find an upload port you should check in the device manager whether you actually get a new COM port when you plug in your ESP8266. If not, you’re missing drivers for a CH340 or CP2102 or whatever USB-serial chip is on there. Or your USB cable is bad. Or your USB port is bad.

yeah - well, again, 8266 board upload was working fine 2 weeks ago before I upgraded CLion plugin and PIO

EDIT: 8266 issue was wth the USB cables (4th one finally worked) - there were just so many issues migrating the ESP32 CLion project that I was the wrong frame of mind.