Clicking Build open a dropdown list

When I click Build a dropdown list appears at the screen top. I started happening only today. What does it mean? How do I get passed it?

o_O did you update VSCode or install any additional extensions?

I updated VSCode May 4th at 2200 hours. Could that have caused it? However, I recreated the project under a different name and included the SSD1306_minimal library using the 'file=" option in platformio.ini and it unzipped it and put the contents in the libdeps folder. The problem with the dropdown list disappeared and it’s OK for the moment.

My VSCode version should be the latest


And my extensions are

Can you reproduce this behavior with the same versions + plugins as mine?

I still have this problem. I close down PlatformIO and open it and the problem is gone.

This is what I have:


and extensions

C/C++ 1.3.1
C++ Intellisense 0.2.2
CMake 0.0.17
CMake Tools 1.7.2
PlatformIO IDE 2.3.2

C/C++ Extension Pack 1.0.0
Notepad++ keymap 1.8.7
Debugger for Firefox 2.9.4

Try and disable or remove these temporarily.

I disabled CMAke and CMake Tools. Inte3llisense cannot be uninstalled. The problem is still there. I opened a project and tried to build it and the dropdown list appears.

By accident I just ran into this issue too, but I immediately noticed what was wrong: VSCode had asked me o to update the C/C++ by Microsoft extension to some -insider version.

Try and downgrade the version.

Hmm false alarm it seems – I it re-upgraded again to the latest insiders version (against my will) and reloaded, then the issue was still gone though… weird…

That’s weird — the “C++ Intellisense 0.2.2” extension by austin is definitely known to cause conflicts with PlatformIO. You should only have the Microsoft one.


I’ve made two additional observations on this since I just got this again:

  • In the “output” tab, there was text regarding PlatformIO failing to contribute a task for some debug configuration. (“PlatformIO Debug (nucleo_f447ze)” for me). I removed some of the older projects in my workspace, the error went away and I could build again
  • a user PIO, VSC can't build, no tasks found - #56 by benn0beam0 has discovered that it may have something to do with an auto-detection setting.

I’ve hit this issue again after creating a new ESP-IDF project and what resolved it for me was a simple VSCode restart.

This issue seems to be very intermittent. I’ve opened issue Intermittent can't build issue, shows "Configure a Task" popup list · Issue #2554 · platformio/platformio-vscode-ide · GitHub for tracking.

Thanks for answering, here everything was running without problems, I didn’t change anything, c++ is the latest version, 1.4 I think VSC is 2.3.2 I’ve tried with older versions for both of them, moved all directly to c:\ for a shorter way, like I use this pc just for my 3d printer, finally after one week I decided to try a factory reset, and the problèm is still there. M’y extension are only platformio Ide, and c++. I tried to load another to help, nothing work. The most strange is that the error appear on line 2 on both configuration. h and configadv. h, these lines are comment. The only change I had one time is that all the commands like #define, or other where error to. On the Marlin, I had more that 70 errors. Really don’t understand why this problem appear without changé.

I forgot, some times hé ask me to configure. json.