Can't upload - Error: Can't find target/stm32f7x.cfg

Hi Everyone,
When I want to upload project I get error Can’t find target/stm32f7x.cfg. This happens on my windows machine. I used to work on Linux and it worked correctly. I haven’t done any changes in the json files that would cause some missing file (at least I am not aware about any).
I searched for the missing file that is mentioned st_nucleo_f7.cfg file i.e.
source [find target/stm32f7x.cfg],
but there is only one occurance in the “…/.platformio.cache\tmp\pkg-installing-x_mzj3o_\scripts\target\stm32f7x.cfg”.

I tried to update libs and etc, but nothing works. What shall I do to fix it?

Content of st_nucleo_f7.cfg
STMicroelectronics STM32F7 Nucleo development board
Known boards: NUCLEO-F746ZG and NUCLEO-F767ZI
source [find interface/stlink.cfg]
transport select hla_swd
source [find target/stm32f7x.cfg]
reset_config srst_only

Error message

GNU ld (GNU Tools for Arm Embedded Processors 7-2017-q4-major)
Checking size .pio\build\nucleo_f722ze\firmware.elf
Advanced Memory Usage is available via “PlatformIO Home > Project Inspect”
RAM: [ ] 0.4% (used 1152 bytes from 262144 bytes)
Flash: [ ] 0.5% (used 2604 bytes from 524288 bytes)
Configuring upload protocol…
AVAILABLE: blackmagic, cmsis-dap, jlink, mbed, stlink
CURRENT: upload_protocol = stlink
Uploading .pio\build\nucleo_f722ze\firmware.elf
xPack OpenOCD x86_64 Open On-Chip Debugger 0.11.0+dev (2021-10-16-21:19)
Licensed under GNU GPL v2
For bug reports, read
OpenOCD: Bug Reporting
debug_level: 1

C:\Users\mateu.platformio\packages\tool-openocd/scripts/board/st_nucleo_f7.cfg:8: Error: Can’t find target/stm32f7x.cfg
in procedure ‘script’
at file “embedded:startup.tcl”, line 26
at file “C:\Users\mateu.platformio\packages\tool-openocd/scripts/board/st_nucleo_f7.cfg”, line 8
*** [upload] Error 1

Remove the folders

  • C:\Users\mateu\.platformio\packages\tool-openocd
  • C:\Users\mateu\.platformio\.cache

and reupload.

1 Like

Thanks! It works now.