PlatformIO Community

Can't set fuses on an Attiny13 via Platform.IO

Hello,
I’m using VS Code with Platform.IO for different newer AVR microcontrollers (Attiny3216, AVR128, Atmega 3208…) for a while now without any problems, but now I ran into an issue I cannot figure out:
I created a project for an Attiny13A, framework is Arduino, platform is Atmel AVR, nothing special; as programmer I’m using an USBASP clone. Uploading works fine, but I can’t set the fuses. I get the message

avrdude: can’t open config file “C:\Users\Win”: No such file or directory
avrdude: error reading system wide
configuration file “C:\Users\Win”
*** [fuses] Error 1

It seems that avrdude cannot find the avrdude.conf, because the path contains a space (The path is “C:\Users\Win 10 Pro…”

What I cannot get is, that the upload works fine with the same tool, only the fuses setting fails?

Ofc I have reinstalled th platform,no change.

The upload related section of my platformio.ini:

upload_protocol = custom
upload_port = usb
upload_flags =
    -v
    -C
    ${platformio.packages_dir}/tool-avrdude/avrdude.conf
    -p
    $BOARD_MCU
    -P
    $UPLOAD_PORT
    -c
    usbasp
upload_command = avrdude $UPLOAD_FLAGS -U flash:w:$SOURCE:i 

Any help would be highl appreciated; thanks!

Try and quote the filepath to avrdude.conf using ".

Thnaks, works when setting two quotes in the upload_command line like
upload_command = avrdude “”$UPLOAD_FLAGS"" -U flash:w:$SOURCE:i
But in the meantime I found it’s an issue in the fuses.py; there was a similar bug on upload: https://github.com/platformio/platform-atmelavr/issues/10. I tried the same change for setting the fuses in fuses.py and it seems to work now without the quotes.

Okay, then this is handled in Setting fuses on Attiny fails due to spaces in path to avrdude · Issue #297 · platformio/platform-atmelavr · GitHub further.