Can't init mbed project


#1

Hey guys,

I can’t init a project for my Discovery, i have an “UnicodeEncodeError”.
Any ideas ?
(It seem that i can’t init a project from mbed framework)

Thanks in advance.

D:\BugPIO>pio upgrade
You're up-to-date!
PlatformIO 3.5.1a3 is currently the newest version available.

D:\BugPIO>pio update
Updating tool-scons                      @ 3.20501.2      [Up-to-date]
Updating tool-unity                      @ 1.20302.1      [Up-to-date]
Updating contrib-piohome                 @ 0.6.0          [Up-to-date]
Updating tool-pioplus                    @ 0.13.1         [Up-to-date]

Platform Manager
================
Platform Atmel AVR
--------
Updating atmelavr                        @ 1.8.1          [Up-to-date]
Updating toolchain-atmelavr              @ 1.40902.1      [Up-to-date]
Updating framework-arduinoavr            @ 1.10620.2      [Up-to-date]
Updating tool-avrdude                    @ 1.60300.2      [Up-to-date]

Platform ST STM32
--------
Updating ststm32                         @ f95053d        [Up-to-date]
Updating tool-stm32duino                 @ 1.0.0          [Up-to-date]
Updating framework-mbed                  @ 4.50701.0      [Up-to-date]
Updating framework-arduinoststm32        @ 2.0.170723     [Up-to-date]
Updating toolchain-gccarmnoneeabi        @ 1.40804.0      [Up-to-date]
Updating tool-stlink                     @ 1.10400.0      [Up-to-date]
Uninstalling toolchain-gccarmnoneeabi @ 1.60301.0:      [OK]


Library Manager
===============

D:\BugPIO>platformio init --ide clion --board disco_f407vg

The current working directory D:\BugPIO will be used for project.
You can specify another project directory via
`platformio init -d %PATH_TO_THE_PROJECT_DIR%` command.

The next files/directories have been created in D:\BugPIO
platformio.ini - Project Configuration File
src - Put your source files here
lib - Put here project specific (private) libraries
Traceback (most recent call last):
  File "C:\Users\CopperBot\.platformio\penv\Scripts\platformio-script.py", line 11, in <module>
load_entry_point('platformio==3.5.1a3', 'console_scripts', 'platformio')()
File "c:\users\copperbot\.platformio\penv\lib\site-packages\platformio\__main__.py", line 126, in main
error_str += str(e)
File "c:\users\copperbot\.platformio\penv\lib\site-packages\platformio\exception.py", line 23, in __str__
return Exception.__str__(self)
UnicodeEncodeError: 'ascii' codec can't encode character u'\ufffd' in position 401: ordinal not in range(128)

D:\BugPIO>

Edit : same error with PIO IDE in Atom


#2

A clean install of the latest dev version of PIO CORE (3.5.1a3) solved my problem… I don’t understand why it didn’t work before.