Can't get PIO to work, Home doesn't want to load


#1

I am running Windows 7 and I have Python 2.7 installed in the ‘C:\Python27’.

I installed VSC without problems. Than there was a column of various VSC components, like C++, PlatformIO etc. I clicked on PIO v0.7.x and it installed itself. As well I’ve set the relevant system variables in PATH.

Anyhow, when all that was done, I’ve restarted PC and restarted VSC and clicked on the little PIO’s Home icon, and I waited and waited and I got this error:

“Unable to open ‘PIO Home’: Could not start PIO Home server: Error: timeout.”

Panes “Problems” and “Terminal” show no errors. My Internet connection works perfectly.

So, I am stuck now and I’ve no clue as to what to do the next. What do I need to do to get VSC & PIO working?


#2

Have you resolved this issue?


#3

No, not at all. Please advise if you can.

I am completely new to this, so I am fundamentally clueless ;-(

I mean whole concept is brilliant, but without support its useless.


#4

Please open PIO IDE Terminal (bottom left corner) and type

pio home

Does it work?


#5

This isnt working for me either.
It was working fine last week on this laptop and it was working fine yesterday on a different computer.
I am using Atom.

When I type in pio home into the terminal I get:
PlatformIO Plus (https://pioplus.com) v0.10.13
CorePackageManager: Installing contrib-piohome @ >=0.3.2,<2
Error: Detected unknown package ‘contrib-piohome’

I have uninstalled and reinstalled platformio. I have also upgraded pip and python to ensure I have the latest version (of Python 2.7).


#6

I’m experiencing the same problem. Home won’t load, I get an endless spinner. Windows 10, fresh install of Atom, fresh install of platformio. The output from pio home is:

PlatformIO Plus (https://pioplus.com) v0.10.13
CorePackageManager: Installing contrib-piohome @ >=0.3.2,<2
Error: Detected unknown package 'contrib-piohome


#7

Fixed. Please restart IDE


#8

Yep, it’s working for me now. Thanks very much.


#9

I just installed VSCode and PlatformIO and am getting the “Unable to open ‘PIO Home’: Could not start PIO Home server: Error: timeout.” error. Can someone help me out?

OS: Mac, High Sierra

echo $PATH: /usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/share/dotnet:/Library/Frameworks/Mono.framework/Versions/Current/Commands

echo $PYTHONPATH:
<>

python --version:
Python 2.7.10

pip --version:
-bash: pip: command not found

pio home:
bash: pio: command not found


#10

I loaded a new version. Still the same problem. Same problem as @12magnette.

Any ideas how to get this to work?

I reinstalled, but it is obviously picking up on the previous installation. Is there way to absolutely clean up traces from the previous installation?

I want to install for ESP32 and Arduino. Is there a no-nonsense installation video I can follow?

I am on Win 7 / Python 2.7.x /


#11

You may find it a weird and nontechnical solution, but I had the same problem as yours.

Just click repeatedly on the home icon of platformio in the left bottom corner and wait the home page to load. This solves the problem for me.


#12

Do you need to do that even after a restart of IDE? Do use Atom or VSCode?


#13

I tried all the suggestions to solve the problem mentioned here and in Github issues. including the restart of IDE. I use VSCode/Windows10.


#14

I must apologize for not reporting back to the forum.

My problem was solved by getting PATH statements sorted out. After a reboot everything started working.

On Windows there are 2 PATH system variables. One is for user’s own account, other is a general one, for all accounts on that PC.

I put all the relevant paths into general PATH system variable, like this:

C:\Python2714;
C:\Python2714\Scripts;
C:\Users(user name).platformio\penv\Scripts;

It is important to install Python 2.7.14 before you install PlatformIO, because PIO is written in Python. If PIO doesn’t know where Python is it can’t install itself.

As well, possibly maybe, Python doesn’t like white space " " character in the path, so maybe it its not a good idea to put Python installation into “c:\Program Files…” folder.

Don’t forget to put a semi-colon “;” on the end of each path string.


#15

If Python is not installed in your system, PIO IDE installer will install it in own isolated folder C:\Users(user name).platformio\python27.

Could try

  1. Navigate to System Control Panel and uninstall ALL Pythons from a system
  2. Remove C:\Users\{user name}\.platformio folder
  3. Restart IDE

Does it work now?


#16

Are you saying that Python 2.7.14 and PIO will work on Windows even if there is a white space character " " in the PATH?


#17

PlatformIO automatically handles spaces, etc.


#18

That’s fine. My question is weather stand alone Python 2.7.14 handles spaces in the path.


#19

What do you mean? If you select “Add to PATH…” using Python installer, it should add correct items to system environment list.


#20

Year ago I was installing Python 2.7.xx and it didn’t want to work if there was a white space in the path. So I was just a bit cautious.