Can't find ide!

I’ve got it all installed, put in my own library, compiled a program I had in Arduino. ALL IS WELL!
Exited out of Platform IO and now I cannot find how to start it. No icon on desktop (win 10), won’t run from command line (search box in win 10). I see my platformio folder and ran some exes but none worked. No context selection either. Tried the same with visual studio…no run.

PlatformIO IDE lives inside VSCode. It is a VSCode extension and is nit stand-alone. For that you need to install the CLI commands as per the docs: Redirecting....

When you open the editor, you will see the toolbar down the left side. At the bottom you should see the PlatformIO icon, looks like an ant/alien head. Click that.

Alternatively, “file->open folder” and open a folder containing a file named platformio.ini will give you access to the bottom toolbar to compile a project.



1 Like

Easier solution… Re-install VS Code, select “create shortcut on desktop”. It really didn’t re-install, because it only took about 5 seconds to come up. Then I had my PIO already installed, clicked on it, found my project. All is well. And I have a shortcut icon!

When I went to the link given, it told me I did not need CLI commands if I used the PIO IDE.

Ok @queenidog , glad you got sorted.

If you only ever intend to compile, upload, run projects from inside VSCode, then it is true you don’t need the commands in a shell/commandline session.

If you might like to do so, occasionally, form a shell/commandline session, then they are useful to have around.

I sometimes need to reflash a different sketch to my Uno (or other boards) so I can pio run --target upload from a shell, rather than opening VSCode and waiting for it to upload, opening the project, and uploading.