Cannot set the upload port


using platformio on Linux
I have a project with portable code for ESP32 and Pico. my problem is that on this specific project, when trying to upload to the pico, the IDE forces the upload on /dev/ttyUSB0 (the usual esp32 port) instead of /dev/ttyACM0, even if I set this port in the platform.ini file, even if I comment out there all the esp32 section

I have other projects that does not have this issue, so it seems to be project-dependant
I noticed that for that problematic project, the IDE forces pio to use /dev/ttyUSB0
Executing task: platformio run --target upload --environment pico --upload-port /dev/ttyUSB0

while for the projects that work, the --upload-port is not used. Did I do something unknowingly in that project to force the port for ESP32? are there other places than platform.ini to force the upload port?

below a copy of the platform.ini file

thanks in advance for your help.

; PlatformIO Project Configuration File
;   Build options: build flags, source filter
;   Upload options: custom upload port, speed and extra flags
;   Library options: dependencies, extra library storages
;   Advanced options: extra scripting
; Please visit documentation for the other options and examples

build_type = debug
lib_deps = 
;	adafruit/Adafruit BME280 Library@^2.2.2
	adafruit/Adafruit BusIO@^1.14.1
	adafruit/DHT sensor library@^1.4.4
	thingpulse/ESP8266 and ESP32 OLED driver for SSD1306 displays@^4.4.0
    gamegine/HCSR04 ultrasonic sensor@^2.0.3
	adafruit/Adafruit Unified Sensor@^1.1.9
	adafruit/Adafruit SHT31 Library@^2.2.0

; [env:esp_wroom_02]
; build_flags = -D HS_PIOWIFI -D LED_BUILTIN=2

; platform = espressif32
; board = node32s
; ;board = mhetesp32devkit
; framework = arduino
; lib_ldf_mode = chain+
; ;monitor_speed = 9600
; ;upload_speed = 921600
; debug_tool = minimodule
; ;upload_port = /dev/ttyUSB0

platform =
board = rpipicow
framework = arduino
board_build.core = earlephilhower
board_build.filesystem_size = 0.5m  
upload_port = /dev/ttyACM0

Then you have /dev/ttyUSB0 set as the forced upload port in the bottom taskbar of VSCode?

Does it say “Auto” for you or did you select a port there?

1 Like

This is it!! Thank you!