Cannot install my custom platform - Error "already installed"

I am in the process of creating a custom platform.

After running into a few issues, I wonder what the correct process is to install a custom platform using Visual Studio Code?

I tried using Platforms > Advanced Installation, then I gave the repo url: GitHub - bergernetch/platform-nocan: OMZLO nocan platform

This is the error message:

PIO Core Call Error: "Platform Manager: nocan@1.0.0+sha.e65ece6 is already installed\nTool Manager: toolchain-gccarmnoneeabi@1.70201.0 is already installed\nTool Manager: Installing tool-nocanc\n\n\nError: Could not find the package with 'tool-nocanc' requirements for your system 'darwin_arm64'"

So, something seems to be wrong with my tool-nocanc (located at: GitHub - bergernetch/tool-nocanc: tool for OMZLO NoCAN). I guess it is because it is not an official tool and therefore it cannot be found?
Can I specify a custom URL in platform.json for “tool-nocanc”? Or can I install the tool by hand somehow?

For more details about the platform, see my older post Error in my new custom platform - #5 by berg

I found two versions of the nocan platform in .platformio/platforms. I removed them both an did the Advanced Installation again.

I still get the tool-nocanc error, but at least the “already installed” problem is gone now.

PIO Core Call Error: "
Platform Manager: Installing git+
git version 2.37.1 (Apple Git-137.1)
Platform Manager: nocan@1.0.0+sha.e65ece6 has been installed!
Tool Manager: toolchain-gccarmnoneeabi@1.70201.0 is already installed
Tool Manager: Installing tool-nocanc

Cloning into '/Users/dani/.platformio/.cache/tmp/pkg-installing-39yklj10'...
Error: Could not find the package with 'tool-nocanc' requirements for your system 'darwin_arm64'"

One step further.
The installation does not fail, when I mark the “tool-nocanc” as optional in platform.json.

But how do I get the tool installed then?

You can specify the version field to be the git URL.

If you specify a version number (like “1.0.0”), it will try to source it from the PIO trusted registry.

Ok, I did add that. But how does the tool get installed, when it is set as optional?

When you set it to non-optional when you need it.

Awesome, thanks for your help! One problems solved :+1: