Cannot install Atmel SAM Platform

I am a foreign developer in China, when I tried installing this platform, it told me these.

What should I do?

Restart VSCode, open a CLI and execute pio platform install atmelsam. What does it say?

Ah, it said “already installed”.
But the final problem is that it cannot conduct the first Project Wizard, which spends about half an hour and did not success,
but terminal said this eventually:

so I tried installing the platform separately.

I’ve never seen this type of error before… Go into Help → Toggle Developer Tools → Console and copy-paste the log content here. Maybe it says something more.

May it cause by the networking block? Because i use manual proxy for VS. PIO cannot even get updated without this…

Did you do your Proxy setup in accordance to the documentation? PlatformIO IDE for VSCode — PlatformIO latest documentation

What do you mean? I’ve ensured that VS networking is accessible. Do it differ to PIO?

But did you do it exactly through one of the options as linked above?

Particularly I’ve set for VS, not settings related to PIO

If you followed the documentation above and it’s still not working, please file an issue in Issues · platformio/platformio-vscode-ide · GitHub.

1 Like