PlatformIO Community

Cannot find mbed BSP_B-L475E-IOT01 library in platformio Library UI

Hi
I have a B-L475E-IOT01A board. Previously, I have tried the Arduino framework. Now, I tried to learn the framework of mbed with plateformio.

I tried to import the library provided by st for mbed library. However, I cannot find the mbed BSP_B-L475E-IOT01, even though I can find it here.

I wonder what is the reason for the above problem and what is the correct solution?

Thanks in advance.

Good question, not sure why it’s not listed. (CC @ivankravets).

You should be able to download the library manually (https://os.mbed.com/teams/ST/code/BSP_B-L475E-IOT01//archive/bfe8272ced90.zip) and add a library.json that specifies the special mbed builder as needed, like in that library.

{
    "authors": {
        "name": "Afdhal Atiff Tan",
        "url": "https://os.mbed.com/users/AfdhalAtiffTan/"
    },
    "build": {
        "builder": "MbedLibBuilder"
    },
    "description": "This library meant to allow mbed boards (tested on F401RE) to act as modbus slave. I don't own this work, I just made some simple modifications so that it runs on mbed. My modification were labeled with \"afdhal\".Summary: Modified modbus Arduino library for mbed. See readme for more details.Feel free to use it as you want.Special thanks to the original authors.",
    "examples": [
        "https://os.mbed.com/users/AfdhalAtiffTan/code/ModbusRTU-RS232/",
        "https://os.mbed.com/users/AfdhalAtiffTan/code/FoodComputerARM-alpha/"
    ],
    "frameworks": "mbed",
    "keywords": [
        "arduino",
        "millis",
        "modbus",
        "modserial",
        "rtu"
    ],
    "name": "ModbusSlave232",
    "platforms": "*",
    "repository": {
        "type": "hg",
        "url": "https://os.mbed.com/users/AfdhalAtiffTan/code/ModbusSlave232/"
    },
    "version": "0.0.0+sha.5318159b5eab"
}
1 Like